Rookie

Rookie

36 points

More About Points »

Gw Senior

Clearwater, FL

gw senior has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Asked: 

my 94 f-150 w/ 4.9 6 cyl needed a fuel pump has been setting for three yrs. pulled the tank and found that the four wire harness was completely off the tank and the end was all apart.I replaced pump using the two wires that I identified by what was left on the pump. then one wire to the float that coincided with the harness. but that leaves one gray wire with a purple stripe that there isn't any obvious place to connect it. needless to say the pump doesn't run at this point.thinking it may be a ground but would rather find out first. pump is new but I still bench tested to make sure it did work. haven't had any luck finding a diagram showing what or where each wire does and its position at the tank or pump. the tank on this truck sets behind the rear end and in the center of the truck ( from side to side ). Thanks for taking the time to read and hoping for your assistance with my problem


Flag This
Question Asked: 

every bulb changed, even swapped complete light from left to right. has no backup lights. can be cause? manual trans. when flasher is changed I get absolutely no lights at all. cleaned all sockets and checked grounds. really need help


Flag This
Question Answered: 

I recently repaired same car, and it was the body mount bushings. the compress over time and become looser which causes them to rattle. but lets hope that it is the spare loose. thank you


Flag This
Answer Ranks