frosty

Rookie
45 points
Recent Activity

Question Asked: When I put the car in park, all of the positions are selected like in all gears.
July 27, 2011, 03:31 PM
I had a used transmission put in about 18 months ago, the shifter has been sloppy since then. The shop I worked with went out of business and I just never took it somewhere else. Is there an adjustment to fix this and tighten up the sloopiness? They are all selected when I put it in neutral also.
Question Asked: will not start battery cause
May 07, 2011, 10:51 PM
was needing a jump to start, replaced battery, fine for about a month, same deal, today will not start even with a jump. at one point when i turned the key, the speedometer went up to about 50 MPH indication and can hear a quite buzzing noise under passenger side of dash.
Question Asked: Transmission clunk now engine does not turn over
March 08, 2011, 01:37 PM
Car was making some minor transmission noises and hard shifts. Before I got it in for repair it had a loud clunk and stopped. Now engine does not turn over either. Had routine maintenance done regularly and only has 95K miles. Is it just the tranny or could it have caused some kind of engine problem.
Question Asked: High rev at startup
February 03, 2011, 09:34 PM
Sometimes the engine has a high rev at start up, 1200 to 2500. It has nothing to do with car or outside temps. Just happens randomly. Drive for a minute and goes away, sometimes comes back when I put the car in park.
Question Asked: noise at start up
January 28, 2011, 10:33 PM
The last couple of mornings, at start up, I hear a grinding and grunting noise. Maybe like old cars with something in the cooling fan. The noise continues for about a minute, after it is warmed up, does not return. If I leave work within an hour or so it does it again (I have a very short commute so does not get fully hot).
Question Asked: Power Window brackets
September 28, 2010, 11:53 AM
The metal plate attached to the window broke off, can it be replaced or does the whole window have to be replaced?
Question Asked: BCM on 2000 LHS
September 17, 2010, 11:53 AM
I had a used BCS installed at a dealer. They stated both of them were not showing any transmission out of the BCM. Both would work initially even though not xmiting but after one shut off and back on we were at the same no turn signals, environment controls, power locks abnormal, interior lights, radio, power windows. I was told the ingnition switch (electrical) could cause this??? Help
Question Asked: replacing BCM
August 30, 2010, 10:15 AM
I am sure by information I received through this site that the BCM is bad. I did a power reset by disconnecting the + battery cable at the positive jump start terminal. That did not change the symptoms. I bought a used BCM but I have read that the BCM must match serial number or a model number?? Any truth to this? Also, I was told if I put in one that does not match my car, it will disable some systems and may never start until a dealer recodes the computers. Please provide some truth to this.
Question Asked: Multiple symptoms at once
August 09, 2010, 08:19 AM
Turn signals, power windows, airconditioner/heating controls, and automatic headlights (manual works) are all not working and the parking brake, ABS, and airbag indicator lights are on all of the time. Also, the heater mode is activated but fan is not blowing. Dont know if it is related, but I had the front struts replaced a week before. Also, the sway bars were replaced at same time.
Question Asked: missing during acceleration
September 01, 2009, 12:32 PM
i recently had the upper engine rebuilt because the timing belt broke. since then when i accelerate fast, 3000 rpm, or while cruising at 68-72 mph the engine takes a hit two or three times. enough that everyone in the car can feel it. the mechanic cannot find the problem.
No activities found
No activities found
No activities found
Answer Ranks