Rookie

Rookie

35 points

More About Points »

Kinzielyn

Dallas, TX

kinzielyn has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Asked: 

About a week ago I stopped to grab my mail on the way home, was only out of the car for about a minute and when I got back in it would not start, no cranking, nothing. I've had all of the common problems in the past so I am usually pretty good at figuring it out on my own, but I had the ECU replaced about 2 years ago and haven't had the security feature problem, or really anything electrical for that matter since. The security light is not blinking or showing, so its not that. I finally disconnected the battery and let it sit for about 6 hours, plugged it in and still nothing. I disconnected again and left it overnight, the next morning I plugged the battery and it and started right up. I drove it 3 days, and then it did it again. I unplugged the battery again overnight, started up the next day and worked until yesterday. I left yesterday morning and it started fine, parked it for about 2 hours and came out and it wouldn't start. I left the battery unplugged overnight and it still won't start. I had the battery tested today, I checked all of the Relays and Fuses, checked the connection to battery. I'm going to have someone come take the starter off and check that, but if it's not the starter I'm at a loss. I've been down this road before and dropped $800-$1000 just on diagnostics, so I do not want to do that. Hoping someone is familiar with these sensitive Grand Am electrical systems might have some advice.


Flag This
Answer Ranks