Rookie

Rookie

35 points

More About Points »

Stephanie C0113

Federal Way, WA

StephanieC0113 has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Asked: 

So when I start my car up it wants to sputter a few times and sometimes even shut off because the idle drops so to low to keep it started. It has always started right back up. Also if I am stopped at a light it will do the same thing sometimes. If im not pushing on the accelerator then it will idle weird and sputter like it wants to shut off. We have replaced the fuel filter and used fuel injector cleaner thinking it is a fuel problem and it was a little better for a few drives but is back to the same thing again.It is happening more and more now pretty much everytime I turn on my car. I don't know if this has anything to do with it but there was also a hose in the front top part of the car that we believe has something to do with the turbo that had a hole that we patched up but haven't replaced yet because we haven't been able to find it, and within the last 3 or 4 days the heat and air conditioning only work at random. My check engine light is on and when I used an OBD2 it said something about the oxygen sensor. And the service light comes on when I start the car but turns off within a few min. When that started I went to get my oil changed professionally but it didn't stop the service light coming on for a min at start of engine then turning off within mins. But they did inform me that I possibly had multiple oil leaks. I am at a loss and I really love this car and its great for my kids and I. I am hoping that its something affordable to fix because I would hate to lose this car.The best car I have owned by far, even with these problems, once I know what to do and how to fix them it will be an excellent car.


Flag This
Answer Ranks