Waynesgarage

Technician
118 points
Where Quality is not Expensive, it's Priceless See us on Facebook & Twitter or www.waynesgarageinc.net
Recent Activity

Question Answered: Having a problem with the starter motor.
February 11, 2014, 11:02 AM
U don't say how many miles r on it. by your description it sounds like a starter motor.
Question Answered: 2001 dodge ram
February 11, 2014, 11:01 AM
trans overhaul needed
Question Answered: My 2006 1500 makes a loud noise when I turn the heat on.
February 11, 2014, 10:59 AM
Sounds like the cage came loose or something crawled in to stay warm
Question Answered: my 92 caprice will start and run for 2 sec then dies. wont idle on its own.
October 23, 2013, 09:38 AM
Have the fuel pressure checked first. When was the last time the fuel filter was changed
Question Answered: The car is running hot after20mins of driving.I can not find a leak. I changed
October 23, 2013, 09:36 AM
Does that mean that u replaced them. Seems like the thermostat could still be bad. Before adding any thing to the cooling system (steel seal) I would have it checked by a professional first
Question Answered: Transmission shifts hard and seems to jump in and out of gear while at speed
October 23, 2013, 09:31 AM
You have to check the fluid, make sure it's full and burnt,burnt fluid may mean that you need a overhaul.
Question Answered: my left turn signals do not work front back or dash have changed bulbs back &
May 31, 2013, 12:09 PM
Did you check the multifunction flasher
Question Answered: All warning lights come when driving on bumpy road
May 31, 2013, 12:08 PM
evidently you answered your on question. have an ASE technician to repair or replace the fuse box.
Question Answered: why is the steering on my truck all of a sudden loose an unstable its scary!
May 31, 2013, 12:04 PM
Sorry I can not give you a definitive answer but if it is scary to drive I would get it to a repair shop as soon as possible before it causes a accident
Question Answered: I need information on a 1981 crown vic. 5.8L 351 winsor engin can you help me.
March 07, 2013, 07:30 AM
have u tried to run the car with the cats disconnected, u don't say why u replaced the cat's. Also what was the cylinder compression readings. how many miles on vehicle, has the timing been checked, could have a loose chain, also does the engine backfire
No activities found
No activities found
No activities found
Waynesgarage's Shops

Answer Ranks