Rookie

Rookie

35 points

More About Points »

Christopher B

Potwin, KS

ChristopherB has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Asked: 

I have a 2000 Mitsubishi Eclipse 3.0 v6 5 speed. The car was starting to get to where it wanted to get hot and when it was starting to get to where it was overheating I always stopped and cut it off. it started to overheat for almost a month and I couldn't figure out what was going on. I always cut the heater on and it would level out or I stopped it I had to. After a Month I finally decided to change the water pump water was coming out of the weep hole. I parked it and replaced the water pump but while I was doing it, taking the harmonic balancer off the crankshaft turned a half a revolution backwards while the timing belt was off. I replaced the water pump and got a new belt but when it came to piecing it back together I couldn't finish it due to weather. I took it to a shop after 5-6 months of sitting there and had the car put back together. They couldn't get the car to start and told me that the spark plugs had to be changed. Well after I got new plugs and wires and a new distributer cap it still wont start. the marks are right and the cam sensor is getting spark, so is the first spark plug. it tries to turn over but its not getting any fire. I thought it might be bad gas or something but I am just not sure. Any help would be greatly appreciated.


Flag This
Answer Ranks