Journeyman

Journeyman

499 points

More About Points »

Mrfordman

Tahlequah, OK

I have worked on vehicles since 1982. ASE Master Tech since 1988. Ford Senior Master Diesel and Gas since 2008. Have worked at Ford dealerships since 1995.


Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Answered: 

what was concern the cables were replaced?


Flag This
Question Answered: 

may have lost high pressure oil pressure that feeds fuel injectors. usually stc fitting on high pressure oil pump blows off. need to get it to someone to read icp pressure. needs 600 psi to start and run. knowing code will help too.


Flag This
Question Answered: 

may be the backing plate for the brake rotor rubbing. need to pull wheel off and check.


Flag This
Question Answered: 

assuming this has automatic temp control, the blower control module will be bad. it is located under passenger side dash mounted to the evaporator case.


Flag This
Question Answered: 

possible vacuum leak or the idle air control valve stuck open.


Flag This
Question Answered: 

having some codes will help.


Flag This
Question Answered: 

yes, have him show you alternator is bad. more than likely battery just bad.


Flag This
Question Answered: 

check coolant level. if ok, possible fuel injector hung open flooding cylinder. will blow white smoke if injector hung open or coolant getting into cylinder.


Flag This
Question Answered: 

seem to get more difficult with brakes applied? if so, steering pump and/or hydroboost unit may be getting weak.


Flag This
Question Answered: 

had one in shop couple of months ago that the engine wiring harness was rubbed through on top of engine. might inspect it real good close to where it is attached to engine.


Flag This
Answer Ranks