mrfordman

Journeyman
532 points
I have worked on vehicles since 1982. ASE Master Tech since 1988. Ford Senior Master Diesel and Gas since 2008. Have worked at Ford dealerships since 1995.
Recent Activity

Question Answered: Motor problems i just replaced my motor now my speedometer don't work and it
September 17, 2013, 01:43 PM
output shaft speed sensor on trans sends signal to pcm. from pcm to speedometer. check sensor and wiring on transmission.
Question Answered: why my car knock when cold stop after it git hot
September 17, 2013, 09:13 AM
need to get it to a shop to see if it is an engine knock or an exhaust leak as both can go away as engine warms up.
Question Answered: truck won't start
September 17, 2013, 08:23 AM
check small wire at the solenoid on the starter. make sure it's tight. also has solenoid on fire wall. neutral switch on transmission.
Question Answered: How 2fix/troubleshoot broken gas pedal, fell 2 floor board?
September 16, 2013, 09:17 AM
ford has a recall on the throttle cable on escape. call a dealer to find out if yours is covered.
Question Answered: no oil pressure
September 16, 2013, 09:14 AM
pretty easy. remove oil filter, remove oil filter housing. has gears inside.
Question Answered: 2004 Tribute Stalls at startup, low idle after opening throttle for 2 mins.Help?
September 16, 2013, 09:10 AM
may still have vacuum leak. check other vacuum hoses.
Question Answered: where does the gray/purple wire go to on the fuel tank.terminals rusted away.
September 13, 2013, 10:02 AM
go to dealer, get a pigtail for pump. has instructions in kit.
Question Answered: 93 Lincoln Town Car ran well last year now only cranks over
September 13, 2013, 10:00 AM
better plan on pulling tank, replacing pump, flush tank.
Question Answered: Starter problems
September 13, 2013, 09:56 AM
need to check neutral switch on transmission. also if shifter loose, arm on bottom of shift column loose.
Question Answered: I replaced the battery and cables. Engine cranks but won't start.
September 13, 2013, 09:53 AM
what was concern the cables were replaced?
No activities found
Car Review: 2009 Hyundai Accent
August 01, 2013, 08:03 PM
Bought this car new. Was driving 150 miles a day back and forth to work. Needed a cheap car that had a long warranty as I was racking up miles on car I was driving pretty quick. Did normal maintenance up to 35k miles. Took to dealer with a/c problem. Compressor bad, headlights peeling chrome inside, trans slip in 3rd gear. Repaired all but the trans. Was told to drive it till trans went out and get it replaced. 55k now and still slips. Other than that, been a good car. Averages 35mpg on highway.
Car Review: 2000 Ford Expedition
August 01, 2013, 07:56 PM
Bought this Eddie Bauer Expedition in June. Had 78k miles on it. Was a trade in with a bad engine knock. Pulled oil pan, #8 rod bearing bad, crankshaft ok. Put it together, have put about 3k miles on it since repair. Drives good. Has 4x4 and air suspension. Not great on gas milage but try not to drive a lot. Great to pull with. Looking for third row seat as it was gone.
No activities found
Answer Ranks