Rookie

Rookie

38 points

More About Points »

Hilliard4

Franklin, TN

hilliard4 has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Answered: 

sounds like you have a spark coil or a boot that's going bad, grounding out some how, make sure all the wires are connected to top of coils and give them a slight tung not to hard just a little as the conectios can break


Flag This
Question Answered: 

you should have a latch on the driver side down near the floor on the left side ,now as to the changing of your spark plugs you will need the keys to start eng ,if you are the org owner of the car you can get ford to make you keys , as to the changing of your spark plugs follow the ford service bulletin TSB 08-7-6 to the letter if you don't you got more problems also make very sure your eng. is cold not warm or hot but cold if you need the ford TSB 08-7-6 let me know


Flag This
Question Asked: 

I have a Auto Computer Diagnostics not just a can reader the mass air flow reads 0.6 at idle and I run it up to 2000 to 2500 rpm it shows 1.4 to 1.6 so do you think that part is bad?? I do have a code P0113 that is telling me the air intake temp side is bad on that part of the MAF ,but no check eng light ,will that cause a misfire like on number 8 cyl and or others at times but not all the time and real bad gas mpg,I do have a 2006 Mercury Mountaineer Premier 4dr SUV 4.6L 8cyl and I'am having a real problem finding this part the ford dealer's don't have it or show a part number for it as you know mercury is no longer ,do you know where I might find this part and or part number I have pulled it and cleaned it with a MAF cleaner but its a no go can you help me thanks


Flag This
Answer Ranks