Kluteman

Rookie
35 points
Recent Activity

Question Asked: fog lights on lex sc400 not working
March 15, 2013, 04:23 PM
does anyone have information on whether there is a seperate fuse for the fog lamps in the sc400... checked bulbs, ok seems like no juice is coming to the lights...also checked all the fuses etc... everything is good. is there something / somewhere else in the car that may be impacting the operation of the fob lights?
Question Asked: any know how to repair the the on/off volume control module for a nakamaichi
March 15, 2013, 04:20 PM
radio in the lexus sc400...the vol/ on/ off module plugs into the head set.. the head set is good and amp is good,, there is an issue with the on/off/vol control itself.... if not, possibly looking to purchase a rebuilt / new one...
Question Asked: i have no sound coming from my nakach radio in any format..cd tape radion am/fm
December 01, 2012, 04:35 PM
changed out the amp today with a used one from an ebay reliable website.. still no sound.. if i change radio is something about some "codes" that i must be concerened with..? if so where do find the codes or get them? thank u
Question Asked: my car had last times belt 100,000 mils ago.. is it time for a new one? i ask be
November 27, 2012, 03:04 PM
because when u first accelerate it gets a feeling of being bogged down then it picks up...even in passing ger sometimes it will bog down before picking up speed..
Question Asked: my car revs high when u first start during hot /cold temp aft 5 min okay, why?
November 27, 2012, 02:59 PM
occurs all the time..even when inside hot garage..or after it has been driven and sat for several hours?
No activities found
No activities found
No activities found
Answer Ranks