Enthusiast

Enthusiast

57 points

More About Points »

Kamikazi2142

Fairfield, CA

Kamikazi2142 has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Answered: 

good luck, these cars are freakin wacko, they rely on so many electricals, getting a diagnostic would be the best idea.


Flag This
Question Answered: 

sorry this isn't an answer, its a request, to bret, please help the MK-1 get well, its been sitting forever, i have a post at the Ford Probe '94 Q&A section. sounds like Sulena has a good deal with the exhaust systems though, i was wondering as well, is welding really better than the, uh, conventional method?


Flag This
Question Answered: 

you should try checking the clutch hydrolic cylinder and add more fluid if necessary, also, these cars are notorious for senseless sensors, try figuring out if the car has one for the clutch, get a Hanes manual and read up.


Flag This
Question Answered: 

heh, it could be your air temp sensor, maybe its registering it too cold, idk, but it sounds like your fuel filter is backed up, you see, when you park for a bit, the particles settle inside the fuel filter, then when you start driving around they pick up and block your fuel again. try changing your fuel filter, see if that works.


Flag This
Question Answered: 

vacuum leaks? lol, is it possible you ran your fuel tank dry a few times? if so, the particles got into your fuel filter, try replacing it. that should fix it, if not check your fuel injectors.


Flag This
Question Answered: 

you may have a bad ICM, i hate that thing, my probe is a '94, but i had similar issues, try changing it, it requires a specific tool to remove, mine was located just under the driver side headlight, down in the void, i is mounted on a heat sink, looks rather out of the ordinary, its for the spark system. it may be your problem... though, the manual says its the hardest thing to check and see if it is working right.


Flag This
Question Answered: 

hey, yeah, if a shop recommended replacing all those parts, they should be held responsible for your current money deficit, but, the best thing would be, using the bus system, go and shop for a shop that will allow a payment plan. what ever happened to the good ol' air cooled Vdubs? are you the only guy who knows it all Bret?


Flag This
Question Asked: 

I am fairly vehicle illiterate when it comes to engines, i got this off a friend he said something was wrong with the Distributor, when i looked it over, the distributor was fine, i got the Hanes book on it, and figured it was the ICM, replaced that, and then i kicked up a storm, but didn't start. Now, it doesn't seem to want to do anything, its just lazy i think. But, the main problem is, when i hook it up to be jumped the spark plugs don't fire, when i use just the battery, disconnected from the jumper car, they do, what the heck? When i would try to start it, it just kicked and kicked before, and just today, nothing, didn't even seem to want to try to kick this time. Any help would be greatly appreciated, i am in the dark, i want to get it to run before i go out and buy two new tires to replace the slashed ones... sold to me as is... lol. This vehicle is a pain in the rear, so many electrical dependencies that it makes a simple fuel filter replacement an adventure. i am hoping on using this car to fulfill my goal of a road trip to my pals in Tennessee, but it needs some TLC now. Please, if you know something and would like to contact me right away, instant message me at: Aim - JediKamikazi2142 Kamikazi21424 Yahoo - Kamikazi2142 Anything is accepted here, i am out of options, i would like to get it fixed on my own, but if not, Auto Repair shop here i come.


Flag This
Answer Ranks