Rookie

Rookie

25 points

More About Points »

Acw8482

Memphis, TN

acw8482 has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Asked: 

I have a 2002 BMW 325ci and on December 9, 2011, i had work done on it to fix a small problem relating to a oxygen line or something to that effect that had burned out. approximately 2 weeks later, i went to get my car inspected for registration and it failed, as the report read that the evaporative system and the oxygen heat sensor monitors (or something to that effect) "were not ready." the folks told me to continue to drive it in hopes that the drive cycle would take care of this problem. so, i called the shop that performed the work on the 9th and they said bring it back in. they then found another problem with a line that also dealt with emissions or oxygen (forgive me for my ignorance) and repaired that and told me that this was likely the problem with the monitors not being ready. they also mentioned something about the secondary oxygen pump maybe being the culprit, which i hope its not being that the pump is approx 300. so, my question is why would it take so long for the monitors to be ready after the initial repairs being that i drove the car everyday and put approx 20-25 miles on it per day? also, is there anything that i can do to help to get the monitors ready? is there something else wrong with my car that is causing the monitors to not be ready? Your help would be much appreciated!


Flag This
Answer Ranks