Rookie

Rookie

45 points

More About Points »

Minimedic

Denver, CO

I just love my car and want it to run properly. :)


Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Asked: 

My heater/A/C control panel isn't working anymore. It was working intermittently for a while, only blowing heat or cold on fan 5 setting, and turning off my headlights when it went off unless manually turned on, then it went out completely. The rider information display went off and on with the A/C, and now it's off too. Is there a fuse I need to check? Or some other information somebody can give me? I have an aftermarket stereo, and that works perfectly. The A/C and rider information display both worked for several months after the stereo was installed. I did have an issue with the ignition switch when I bought the car, but that was fixed as well, and the A/C worked for 2 years after that. Any ideas?


Flag This
Question Asked: 

I had the key for my car copied and didn't realize that it wasn't a microchipped key. My car was running perfectly. Then I tried to start the car with the new key. Started fine, stalled 3 seconds later. Did this twice, figured out the new key wasn't microchipped. Have been using my original key since. However, now my car won't accelerate, even on highways. Once up to running speed, it runs great, but it still sounds like it wants to sputter and it seems to sputter louder when idling. It doesn't stall, it just sputters. I don't know how to describe it, but when attempting to accelerate, it feels like the car can't breathe. Any ideas?


Flag This
Answer Ranks