Enthusiast

Enthusiast

53 points

More About Points »

Mark2 1

Philadelphia, PA

mark2-1 has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Answered: 

sounds like you have a blown head gasket


Flag This
Question Asked: 

I just put a new timing belt ,thermostat, and water pump in but none of my belts r turning only the timing is turning but the car run rough and when I start the car i can hear the timing belt turning


Flag This
Question Asked: 

when i went outside this morning my car wont start so i cleaned off my battery terminals and it started right up so then when i get to my uncle house i leave it and try to start up it up and it wouldnt start so i push it to the gas station i put some gas in it and it still wouldnt start idk what is . could it be the fuel carbinator,fuel filter what can it be


Flag This
Question Asked: 

i just got a new battery 2 weeks ago and just 3 days ago which was Monday Dec. 28,2009 i came outside to start up the car and i heard 3 clicks and then it started up and when i park the car and turned it off the next day i came out to start it and all i seen was the dashboard lights came on for the seatbelts,battery,oil. but i was wondering if the three fuses on my postive cable on the battery was the problem


Flag This
Question Answered: 

i just got a new battery 2 weeks ago and just 3 days ago which was Monday Dec. 28,2009 i came outside to start up the car and i heard 3 clicks and then it started up and when i park the car and turned it off the next day i came out to start it and all i seen was the dashboard lights came on for the seatbelts,battery,oil. but i was wondering if the three fuses on my postive cable on the battery was the problem


Flag This
Answer Ranks