Enthusiast

Enthusiast

82 points

More About Points »

Scvscions

scvscions has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Answered: 

sounds like a bad oil pump if the filter is correct. Change the oil filter with a different brand, per. WIX and recheck.


Flag This
Question Answered: 

the engine has a code, it sets all the lights so you take care of it. probably a misfire in the engine and it needs plugs. Need a code reader to see whats going on.


Flag This
Question Answered: 

exactly, you'll know when you're doing it correctly cause there will be lines where the odo reading is and they disappear then zero out and its done for 5000 miles. You can also set it for a lessor mileage by letting go at anyone of the 5 - marks. Every - mark is 1000mi.


Flag This
Question Answered: 

You'd have to ohm out the gas gauge wiring when its failing to see if its the gauge or the sending unit


Flag This
Question Answered: 

Not really that hard to do, drain the coolant, remove the belts and remove the pump, then install. Pump comes out from the bottom.


Flag This
Question Answered: 

door lock computer is probably bad, just had to replace one in a tC


Flag This
Question Answered: 

you'll have to see how much 134 is in the system, if it's too low the compressor wont turn on


Flag This
Question Answered: 

If you have air in the system it will not work correctly. You'll need to get another ac service where the remove the 134a, and vacuum the system fro 30minutes, then reinstall the 134. If still a no go(compressor wont turn on) then there is a problem with one of the sensors.


Flag This
Question Answered: 

Get a quote from another shop or two


Flag This
Question Answered: 

usually happens when the tires are going bald if you're on dry even road when it happens


Flag This
Answer Ranks