» » »

Nissan Q&A

Ask Your Question

1995 Nissan Quest Question: ****UPDATE**** on the 95 mercury villager/nissan quest with bad knock sensor

 

Question

damnvillager, 3.0L V6, Vallejo, CA, October 09, 2012, 13:07
 Rookie

SO I Finally bought a compression tester and did a compression tester on the van.

All but one cylinder has good compression.. one cylinder has zero compression!

I don't know how this could have happened! It's a low mileage engine..108k.. Did I cause this problem? Could a weak cylinder be the reason it had been throwing a knock sensor code??

Any suggestions what it could be? probably the rings?

Thanks in advance,

Any Advice is appreciated

1 Answer
Flag This
  • Answer #1

    pushrod October 09, 2012, 19:32
    Profile_thumbnail
     Master

    YES ON KNOCK SENSOR CODE,MOST LIKELY VALVE PROBLEM CAUSING LOW/NO COMP.
    CAN PUT ABOUT A TABLE SPOON OF OIL IN THAT CYL. THEN CHECK COMP. IF IT COMES UP
    SUSPECT RING PROBLEM,IF NOT SUSPECT VALVE PROBLLEM. EITHHER WAY THAT HEAD WILL NEED TO COME OFF.
    GET A MECHANIC TO LOOK AT IT BEFOR ANY WORK! REMOTE POSS. STICKING VALVE.
    GOOD LUCK!

    Flag This
  • Reply

    damnvillager, October 09, 2012, 20:04
     Rookie

    Werty

    Thanks for the response! when I first checked the compression that bad cylinder was registering less than 5PSI it would stay on zero but when I pressed the release valve a little air would come out. I did put a little oil in it and try it again, it then registered around 15 PSI maybe a little less.. would this be a ring problem? or could it still be a valve? I tried to edit my original post but I wasn't allowed to.

    SO it wasn't something I did wrong? I've been feeling like I did something wrong, But I couldn't get it to pass smog earlier due to high NOX which I was told was caused by high cylinder temp.. possibly due to the burned valve?

    I will have to have it towed to a mechanic If because I don't think it would be good to drive it! I hope it could just be a burned valve.. I noticed before on the specific cylinder the spark plug looked pretty burned.. maybe detonation?

    Flag This
  • Reply

    pushrod, October 09, 2012, 20:17
    Profile_thumbnail
     Master

    BEST "GUESS" IS VALVE PROB. AND BEST TO TOW TO SHOP. GOOD LUCK. BUT CHECK ON ANY RELATED PROBLEMS WITH MECHANIC.
    LIKE VALVE STICKING IN VALVE GUIDE! I DON'T KNOW OF ANYTHING BUT IT STILL MAY BE A PROBLEM WITH THIS ENG.

    Reply
    Flag This