Turn Signal and Brake lights don't work. on 2007 Ford Taurus

Very strange situation. My brake light doesn't work when the brake is pressed. Also, my turn signals don't flash in the back. The Turn Signals work in the front however they blink faster than they did when it worked fine before. The only light that works during the brake being pressed is the middle light. The other two just don't work at all. I know it's not a fuse or a blown light bulb though. I'm not sure what else it could be.

by in New Castle, PA on January 05, 2010
2 answers 1 comment
ANSWER by on January 27, 2010
Hello, Sorry to see you didn't get some help with this. Were you able to figure out the problem with the lights? Was the brake switch bad? Bret
2 people like thisFlag inappropiate
COMMENT by on February 09, 2011
I have the same problem as well, but I'm leary about throwing parts at it not certain what the real problem is. I have no testing equipment, but i could jump the leads if this on the recomended list. Any thoughts on this? OK I jumped the leads. There are 2 switches. One on the arm, and one on the pushrod. individually i got the left to blink and brake, but no dice on the right. when jumping them both at the same time, i had no improvement. I then pulled every fuse and inspected them. all was well. I reassembled and resigned when my kid "bonked" the tail-lights and insisted we check them. Tah-Dah ! Everything works as they should, but a flasher relay is on my list, as i too had the rapid flash syndrome as well. May Lady Luck be on your side as well.
ANSWER by on February 16, 2011
have not check the fuse whay size of fuse is it
Related Items:
When I push the brake pedal my brake lights work, but then I push the pedal again and they don't work. What could this be?