» » »

BMW Q&A

Ask Your Question

1990 BMW 325i Question: Trouble Starting

 

Question

Cladoris_Paris, Hyattsville, MD, May 04, 2010, 14:38
 Rookie

i have a 1990bmw 325i. i turned the car off one day. ran in the store. ten minutes later came out and the car wouldnt start. left the car. came back thirty minutes later the car started. drove the car 25 miles. pull up to a gas station. turn the car off pump the gas get back into the car. the car wouldnt start. waited 5 minutes and the car started.arrived at destination. left destination 40 minutes later and the car started right up. drove 25 miles to home. next day i drive 25 miles from home get to destination. run in. come out 15 minutes later car wont start. leave car for two days. go back to check and car starts right up. i still leave the car. later on go back and get the car. it starts and i drive home 25 miles. now car wont start. kinda sounds like the ignition is working by itself.

3 Answers
Flag This
  • Answer #1

    Visitor, June 27, 2010, 20:58

    i had a 1985 325i same problem it was a bat. cable conection in the trunk

    Reply
    Flag This
  • Answer #2

    Visitor, August 23, 2010, 13:32

    I have a 92 BMW 325i and have somewhat the same problem. I find that when I take both computer units (located behind a panel under the hood parallel to the glovebox) out and let them cool, the car starts rite up. Although it's a pain to have to do this whenever it happens, it gets me back on the road faster.

    Reply
    Flag This
  • Answer #3

    Visitor, December 08, 2010, 10:30

    it could be the main ecu relay thats what was happening to mine and i changed it and now it starts up just fine

    Reply
    Flag This