Chevrolet Q&A

Ask Your Question

1997 Chevrolet Suburban 1500 Question: trany problems

 

Question

Rudedog, 5.7L V8, Los Angeles, CA, August 13, 2009, 21:40
 Rookie

My burban runs great thanks Chevy-pro for your help. Unfortunately I have another problem. It runs great and smooth on drive however when I place it on reverse it gives a loud bang and does not move and makes a clanking noise until i shift it on Park. any help would help.

2 Answers
Flag This
  • Answer #1

    ProChevy August 14, 2009, 11:12
     Journeyman

    From your comments it's very likely you have some major transmission problems. If the truck drives fine in forward gears and won't move at all in reverse, I would suspect something on the reverse input drum possibly. My advice would be to take it to a good trans shop and ask them to drive it and get an opinion and then go from there. Good Luck

    Reply
    Flag This
  • Answer #2

    Russ August 14, 2009, 11:17
     Master

    If the noise is coming from the transmission I would suspect an internal fault with the transmission. If could be something else in the driveline causing the banging noise. You can try listening under your Suburban while having someone shift from park to reverse to see if you can tell where the noise is coming from. Please be careful and have the park brake applied and have your helper step on the brake pedal while shifting from park to reverse. If you don't feel save checking for the noise in this manner please get some help from a qualified technician.

    Reply
    Flag This