1997 Chevrolet Suburban 1500 Q&A

1997 Chevrolet Suburban 1500 Question: trany problems

My burban runs great thanks Chevy-pro for your help. Unfortunately I have another problem. It runs great and smooth on drive however when I place it on reverse it gives a loud bang and does not move and makes a clanking noise until i shift it on Park. any help would help. -
Answer 1
From your comments it's very likely you have some major transmission problems. If the truck drives fine in forward gears and won't move at all in reverse, I would suspect something on the reverse input drum possibly. My advice would be to take it to a good trans shop and ask them to drive it and get an opinion and then go from there. Good Luck -
Answer 2
If the noise is coming from the transmission I would suspect an internal fault with the transmission. If could be something else in the driveline causing the banging noise. You can try listening under your Suburban while having someone shift from park to reverse to see if you can tell where the noise is coming from. Please be careful and have the park brake applied and have your helper step on the brake pedal while shifting from park to reverse. If you don't feel save checking for the noise in this manner please get some help from a qualified technician. -
Related Items:
I was experiencing what felt to be transmission slipping when the truck would shift from 1st to 2nd at slow speeds. I had the trany fluid changed, but it no more than regular wear as far as metal. ...
The transmission was replaced a short time ago and has 10000 miles on it. It suddenly stopped working in drive and O-drive from a standing start. It works fine in low gears at the start, then I can...