» » »

Mercedes-Benz Q&A

Ask Your Question

1999 Mercedes-Benz SLK230 Question: Transmission wont shift out of first

 

Question

steve18015, Hellertown, PA, September 02, 2012, 08:12
 Rookie

When I start my car in the garage and back out and put in drive it wont shift out of first gear. It is a little cool in the garage. If I drive around the cul-de-sac for ten minutes, park, reverse, on and off, it may start to shift. Or if I park it and come back later it works. What is weird is when I park outside and it is warm (75+ degrees) it usually works fine. It does idle rough at first til it warms up but I have dumped over 4 grand on this car in the last few months (tune-up, coil springs, relay for supercharger so on and so on) and dont want to dump too much more. I took it to aamco and they checked it over and said it was ok. Still have the problem though. The only codes are for air cond.

1 Answer
Flag This
  • Answer #1

    September 02, 2012, 08:35
    Profile_thumbnail
     Master

    it sounds like valve body issues. did you leave it at aamco for them to experience it cold???

    it will be somewhat expensive if it is the valve body as it is a mercedes. when was the last time you serviced the transmission??

    roy

    Flag This
  • Reply

    steve18015, September 02, 2012, 09:22
     Rookie

    Yeah, I left it overnight but they said everything was fine the next day. Since I took it there for that particular reason I assumed they checked the fluid but now I doubt it. I just bought it used in Feb. so I dont know when the last time it was serviced was. Its looking like it might just get sold or traded in at this point. It is just odd to me that it works absolutely fine one day and the next it has this problem like it just has to warm up or something.

    Reply
    Flag This