1997 Mercury Mystique Q&A

1997 Mercury Mystique Question: Transmission Problem

Haveing trans problems. When I start the engine, I let it warm up for 1 min. Then I put it in drive, will not move forward or backwards. After a few mins it moves. It only does this when it is cold. Need Help. -
Answer 1
Many possibilities. Has the fluid level been checked? When's the last time it's been changed? Seals (internal) may be brittle and leaking (pressure , internally). Clutches may be worn. Electrical , but that seems unlikely. I had a '94 Dodge Intrepid with those symptoms and I got away with replacing accumulator piston seals and that fixed it for another 60K. BUT I was lucky.......... Best bet is to have a trans shop (get references) look at it and give you an estimate. Good luck. -
Comment 1
Thanks for the info. Ed -
Related Items:
I had a remodeled transmission installed. I lasted 8 months and my car stopped moving. I've taken it in and they want to install another transmission for over $2,000 with a 3 yr. warranty. This ...
automatic transmission problems. slipping, hard shifting, safety mode
I REPLACED THE INPUT SPEED SENSOR AND THE TRANSMISSION STILL JUMPS BACK AND FORTH IN GEARS.yOU WILL BE DRIVING ALONG AND THE TRANSMISSION WILL JUMP DOWN TO A LOWER GEAR AND THEN JUMP BACK UP TO THE...
Transmission problems are common in this model, often as a result of a failed front pump. The pump loses its abili...
catalyst code and transmission code code comes on after a few weeks of driving car runs fine unless driving for long periods of time