Plymouth Q&A

Ask Your Question

1999 Plymouth Grand Voyager Question: Transmission Not Shifting And Dashboard Lights Not Working

 

Question

miseve2002, 3.3L V6, Robstown, TX, September 30, 2009, 11:07
 Rookie

I've had a problem with the Transmission Speed Output Sensor.At least that's what I thought it was --I've replaced 3 already and each time the EATX fuse blows.I've replaced the 3 sensor, but it is not registoring and transmission and dashlights where P/R/N/D are not working either.When it shifts past !st gear it dies.I think it has something to do with Input/output sensors are the EATX fuse.I don't want to drive it to a Auto Parts to put it on computer--afraid it might make it worse to drive it.Can some1 plase guide me.I heard something about a solenoid pack also ---Don't know what it is are where to find this things in referrence to the transmission output sensor I already changed---Please any hekp would be appreciated can't afford a Auto shop wish I could.

2 Answers
Flag This
  • Answer #1

    sinautoscan.com September 30, 2009, 12:16
    Profile_thumbnail
     Master

    You should try to check out the TCM transmission control module if its bad is going to give you false readings did you get a code from the car? i can look it up

    Reply
    Flag This
  • Answer #2

    Visitor, August 04, 2010, 19:06

    buy a toyota or a honda i have the same problem i replace tha trans.. 2 times in 18 monts i am not goin to put a dime on this sH*** any more good luck

    Reply
    Flag This