TRANSMISSION "LAG" between 1st and 2nd GEAR... CALL LEXUS to COMPLAIN 1-800-25 LEXUS !!! on Lexus RX330

Average mileage: 91,633 (40,000–145,000)
3 model years affected: 2004, 2005, 2006
13 people reported this problem
Get Your Car Fixed at a RepairPal Certified Shop.
We certify shops based on expertise, quality work, and verified customer reviews
Viewing 1 - 8 of 8 problem details
Just spoke with my Lexus dealership. Svc. Tech knew exactly what I was talking about and said he'd had "numerous" complaints. Basically, the problem is the SENSOR from the foot pedal to the engine. Very common in 04-06 RX and EX models! He reported that THE SOFTWARE UPDATE does not stop the problem... And said there IS NO FIX, and that if I wanted to " fix it"... I'd want to consider going to a '07 model or newer. Said Lexus never sent out any kind of recall, BECAUSE THE PROBLEM CANNOT BE FIXED!!! AM I CRAZY FOR FEELING THAT THIS IS JUST PLAIN WRONG??? I'm furious! I am calling Lexus' corporate complaint # at: 1-800-25 LEXUS!!!!!!!!!!
2005 Lexus RX330 40,000 mi,
Trans shift lag between 1 & 2...90k miles & getting worse. Software update did nothing.
2005 Lexus RX330 90,000 mi,
Mine does the same thing since I have had it.
When switching lanes or merging into traffic from an on ramp there is a delay while accelerating. It's dangerous and frustrating because you really can't gauge how much time you will actually need to make a safe lane change.
2004 Lexus RX330 81,000 mi,
I have also noticed a delay or jump in the transmission when slowing or accelerating between 0-40 mph. I have a 2004 with very low mileage, only 81k miles. Has anyone had major transmission damage or issues with this? Or is it just something to deal with? I have repaired a transmission in a vehicle once before and I just don't want to go down that road again.
2006 Lexus RX330 129,000 mi,
When i first bought this vehicle i thought it was shifting gears funny. I took it to several mechanics on to hear nothing was wrong. Now a dew months later i have this transmission problem.
2005 Lexus RX330 77,000 mi,
Still have issue.
Same problem above