transmission failed on 2000 Mitsubishi Eclipse

Hi! I have a 2000 Eclipse GT 3.0 with the sportronic transmission, shortly after buying the car, the trans started slipping, harsh engagement, in and out of gear. finally went into Limp home mode, DTC codes P0750 and P0755 (Shift solenoids A&B malfunction) then it started making grinding/whining noises. bought a used 60K mile transaxle, swapped it out, changed the filter (had to split the case) changed the fluid and went to test drive the car- didn't get two blocks before the car jerked and went into limp home mode. took the car to the dealer, they said one of the speed sensors wasn't being read buy the PCM, possibly a broken wire/sensor. I'll have to see what sensor they were talking about. I know there are three- Input speed sensor, output speed sensor and VSS sensor. I believe the VSS sensor is fine, otherwise my speedo wouldn't work. as for the other two, I'm not sure how to check them, I am looking into getting a factory service manual right now. let me know if you can help me out here, I'm going crazy with this car........ Thanks! Ben Smith

by in Kansas City, MO on January 03, 2013
0 answers
Related Items:
The front, lower ball joint may fail unexpectedly resulting in loss of vehicle control. Failed ball joints will require replacement. Our technicians recommend a complete inspection of related s...
Have replaced the ignition lock but has not eliminated the problem. Sometimes it will start and sometimes nothing happens.
my master clutch cylinder, & the slave, were replaced too, both are new, why my shifter feels hard to get into...
The car is running but I can't shift