Car Problem Reports

Lexus RX330 Transmission Control Software Update Available

 
Lexus RX330 Problem
30 Reports
Me Too
Edit

Model Years Affected: 2004, 2005, 2006

Average Mileage: 85,666 mi (35,000 mi - 160,000 mi)

Verified

A shift "lag" may be noted when accelerating from speeds of 10 to 20 mph. A software update for the transmission control module has been released which may correct this concern. Software updates are commonly most effective on newer vehicles. Higher mileage vehicles may exhibit a similar symptom caused by a component failure. However, whenever major transmission repairs are performed the transmission software should be checked and updated as necessary.

  •  Rookie

    My 05 RX330 (original owner) has had this transmission "lag" between 1 and 2 since 40K miles... It's now at 86k and getting worse! I AM SO GLAD I'm not crazy for noticing this problem... my husband never "senses" it!!!

    Is this a recall issue? Should I contact my dealership? Thanks for any help!

    UPDATE: See my post titled TRANSMISSION LAG. CALL LEXUS AT 1-800-25 LEXUS !!!

    Flag This
  • Visitor, , 85,000 mi

    Same issue. Dealer says our module software is up to date. Still reporting problem to dealer

    Flag This
  • Visitor, , 101,000 mi

    I am researching to find out what needs to be fixed...

    Flag This
  • Visitor, , 64,000 mi

    SHIFTS WIERD BETWEEN 1 AND 2

    Flag This
  • Visitor, , 80,000 mi

    While driving casually, around 35 mph, the transmission shift really hard, like a delay and then lunges into gear.

    Flag This
  • Visitor,

    I've had the same problem for over a year in my 2004 - I am the only driver and when I have someone else drive it - they say its fine - I am just glad it's not my imagination - it's is real !!

    Flag This
  •  Rookie

    I just started noticing a lag in in the transmission shifting at about the 20 mph mark when the transmission is to shift from 1st into 2nd gear. I took it to a transmission specialty shop & was told that the transmission fluid definitely needed to be changed, but they also suggested a "purge" & cleaning of the transmission which was an additional $300 but would most likely correct the problem. I went ahead with their suggestion and when it was finished I pulled out of their lot and it did the EXACT same thing as before they did their work and the problem is now WORSE than before they touched it. Any ideas on what may actually be causing it?? I am calling the dealership this week and will probably be taking it up there.

    Flag This
  •  Rookie

    shitling lags and kinda scares me while its shifting from first to second shift. I was told it was due to the kind of gas I was putting in. Due to the economy I was using regular unleaded so I was told to change back to premium. I still notice the problem?

    Flag This
  •  Rookie

    Lag/hard shift around 35 mph

    Flag This
  • Visitor, , 90,000 mi

    Same problem here

    Flag This
+ See more reports