1996 Toyota Tacoma Questions

Answered 1996 Toyota Tacoma Questions

Ask a Question
View:RecentAnsweredUnanswered
It is cold air.. Some times the belt gets stuck and it smells like burning rubber. Is it the clutch or the Compressor?
The compressor never cycles before burning the fuse. I installed a new compressor, dryer, etc.. Please tell me which part I need to replace to correct this problem. Thanks!
It never did this until my old ladys brother fixed the steering stablizer,cause?
This is the second ball joint failure for this truck in 3 years...I have approx. 238,000 miles on it now....Both times have happened while driving...the one tonight at highway speed....Thankfully was able to get it o...
new plugs,distributar,o2 sensors,egr cleaned,mass air cleaned,
I would lik to replace the heater control valve on my 1996 toyota tacoma and am not sure where to start looking for it?
blew the fuel system out with air,got the truck to run for 3 days,put seafoam in tank now it will not stars
what could it be? theres many things ive looked up and i dont want to spend thousands on a bunch of different things if they fix the wrong thing. also, check engine light is always on. but truck seems to run great! bu...
1996 toyota tacoma, 4 wheel drive, 2.7 engine, when cold the engine starts perfect, but when you shut id down, it will start back immediately, but if you let it set for 15 or 20 minutes it want start, i put a new fuel...
the ignition switch was left on over night.next morning we charge the battery and now the truck will not start.before the key was left on the truck ran great
having a misfire problem scanner will show all cylinders misfiring at times the faster the engine runs the worst it gets but idles great and starts good hot or cold also gets fair gas mileage 193000 miles
Turn the key and everything lights up but the start is dead. after a few more tries it starts. Replaced the ignition switch, no help.
pulled my truck into the garage, installed a new stereo, messed with the stereo with the car off and now it wont start, the battery is charged and everything works but the engine wont start