2004 Toyota 4Runner Questions

Unanswered 2004 Toyota 4Runner Questions

Ask a Question
View:RecentAnsweredUnanswered
my oil was low, my husband had a hard time determining when it reached the right capacity. I'm afraid he added too much (1 1/2 qts) Could this have cause it to start shimmying slightly at traffic lights when it never ...
I have driven for about 2500 miles before I noticed that my transmission oil was low. I could smell the burning oil a few times over that time. But why didn't the A/T oil temp light go on? I know the light works.
My 4 runner is a 2004 v8 engine with all time 4wd. I currently have the same issue as others have posted with VSC and check engine lights. Im not sure if these problems are related? However, when I accelerate I hear t...
would my 4runner have any complications if it is always used on axillary (H4)?.
why is my steering vibrating when ever m on top speed 140km/h and steps on my brake pedal, my alignment is ok..
VSC LIGHT AND CHECK ENGINE LIGHTS ON AND WHEN I START THE VEHICLE SOME SMOKE COMING OUT OF THE EXHAUST PIPE. THE VEHICLE HESITATING TO ACCELERATE FINE.
A little to none but when i go down a steep hill and apply the breaks the pedal and steering wheel start to shake bad that i have to take my foot off the pedal and drop the trans to 3rd and use lite steady pressure wh...
The car is kept in garage and is in mint condition except for the cracks on the dashboard and is growing. Also you can file a complaint on: http://www.nhtsa.gov/Vehicle+Safety/Recalls+&+Defects
the lite will go out after switching to 4wheel then back to 2wheel -seems to shift from 2wheel to 4wheel - but no matter any time the key is off and on again it is always in 4wheel mode dont notice any codes coming up
I had front brake pads and some other service on my Toyota at the dealership. When I drove the vehicle the pedal was much lower than before. I brought is back and they say nothing is wrong but the pedal is much lowe...
My radio/stereo on my 2000 toyota 4r won't come ON at all. Fuses are OK. ?????
The system will not turn on at all. I have checked the 2 fuses under the hood and I have unhooked the battery to try and reset the system. Is there anything else I can check?
My 4runner seems to shift too qickly, jumping to 4k rpm. Pulling a 2100 lb trailer is difficult. The 4runner constantly shifts. Mileage cut in half (8.3 mpg) could the problem be the speed sensor? If not, what mig...