temperature gauge on 2002 Mitsubishi Galant

This problem started about two months ago. When you start the car, the temp gauge goes to about 1/2 between hot and cold. When you first accelerate it is okay for awhile and then it creeps up a little. The temp will start to creep up when you are idling and comes down again a little when you start to drive. The car has been in the shop 3 times for this same problem. It has a new radiator, water pump, hoses, the sensors have been checked and it has a new thermostat. Any idea what the problem could be?

by in Newark, DE on May 30, 2011
1 answer 5 comments
ANSWER by on May 30, 2011
to be honest, it sounds normal to me. when idling, it will heat up, then the fan will kick on and drop the temp. normal running is about 1/2 between cold and normal. under a load, it may heat up a little but fans will turn on and cool it back down. did this just start?? has it overheated?? is this a change from the past?? Roy
COMMENT by on May 30, 2011
I'm. sorry. I guess I forgot to indicate that the car runs hot. Iss it normal to go straight to 1/2 when you first start it and then less than mins be up to between 1/2 and 3/4 hot? The fans also work.
COMMENT by on May 30, 2011
ok, makes sense. i suggest you get a cylinder leak down check on the cylinders to verify that you are not burning coolant from a head gasket or cracked head. i would start there to verify your motor is in good shape. Roy
COMMENT by on May 30, 2011
OK. That, too, has been done. That's why it is so odd that it has not been able to be repaired yet. I guess I will have to get a diagnostic.
COMMENT by on May 30, 2011
that would be a good idea. have you had it to a shop?? if so, i suggest another shop with another opinion. Roy
COMMENT by on May 30, 2011
It has been in the shop 4 times for the same thing. Hopefully the diagnostic will give us a positive answer. Thanks for your help.
Related Items:
Temperature gauge is dead. Any suggestions?
...out and they replaced it, along with a flush and fill. I still have the same problem! The car runs hot even on the freeway and with summer coming, I am afraid it might overheat. I don't hear the co...
We just replaced the temperature sensor but the temp gauge still shoots up all the way to red and my engine light stays on since then.
Also temperature gauge isn't working too, so I can't see what is the real temperature of the engine. Thank you fo...

Related Content