» » »

Cadillac Q&A

Ask Your Question

1994 Cadillac Seville SLS Question: stop engine low oil pressure message and chime comes on

 

Question

Bwi, Benton Harbor, MI, January 31, 2014, 10:31
 Rookie

sometimes the message comes on, some days not. Replaced oil pressure switch at dealer and the message and sound was constant so they reinstalled my old part and I am back to the sporadic message and sound. It must be a false read. Dealer said oil pressure was at 12 psi at idle and increases with rpm it should be at 5 psi at idle. Now they say it might be a faulty ipc (instrument panel control). How can this be fixed or can the warning sound be disconnected, the message I can live with but the warning sound is irritating. Before the dealer experience, another shop said oil pressure was good and replaced the current oil switch. So the switch that I have is actually a replacement from the OEM part.

1 Answer
Flag This
  • Answer #1

    G. T. Service Center (4071 Answers) , Stephenville, TX - (254) 638-3236
    ProfessorG January 31, 2014, 10:45
    Profile_thumbnail
     Master

    What brand and weight of oil are you using.

    Flag This
  • Reply

    Bwi, January 31, 2014, 11:01
     Rookie

    Using 5w30 super tech from Wamart but have used 10w30 also

    Flag This
  • Reply

    ProfessorG, January 31, 2014, 11:49
    Profile_thumbnail
     Master

    Does it do this while you're driving, or at idle only.

    Flag This
  • Reply

    Bwi, January 31, 2014, 11:59
     Rookie

    Does it mostly when at a stop or when stopping but also driving. Massage and sound will appear but then go off and then not happen for two days or so. When the dealer changed the oil switch or sending unit it was chiming with message on display to stop engine oil pressure low and would stop driving out of the shop, so they replaced my part back.

    Flag This
  • Reply

    ProfessorG, January 31, 2014, 12:31
    Profile_thumbnail
     Master

    It's signal goes straight into the cluster, but the ground wire might be an issue. If it's a Northstar the ground should be on the top left of the engine, if just a 4.9L it should be on the right front of the engine. Check and clean all the ground connections you find, then try it.

    Flag This
  • Reply

    Bwi, January 31, 2014, 12:44
     Rookie

    It is a Northstar engine, any other suggestions let me know, I will check the ground wire.

    Thanks

    Flag This
  • Reply

    ProfessorG, January 31, 2014, 13:08
    Profile_thumbnail
     Master

    It has to get an electric signal and if the ground is bad it will change the signal.

    Flag This
  • Reply

    Luv My Caddy, February 17, 2014, 12:14
    Profile_thumbnail
     Rookie

    Like to know if your issue was resolved by ProfessorG?

    Flag This
  • Reply

    Bwi, February 17, 2014, 12:43
     Rookie

    No, Could not fine a ground at top of left side of engine, only ground I see is on front of engine which is the battery ground. 94 cadillac gave out on the road while heading to the shop that rebuilt my transmission. Something did not sound right , car was not shifting and loss of power, was towed to the shop, car would not start there was no warning message on the display.

    Reply
    Flag This