Starts, Runs till warmed up, Dies. What to do? on Dodge Ram 1500

Average mileage: 135,750 (60,000–179,000)
6 model years affected: 1999, 2001, 2002, 2003, more2008, 2010
16 people reported this problem
8 people shared problem details
I have a 2002 Ram 1500 4x4 5.9L, truck will cold start run for 10 minutes until its warmed up then die and it wont start again until its cold again. replaced ignition coil because i had no spark there after it died and that didn't fix it. I have fuel pressure and a full charge on the battery. no codes with computer from NAPA. Any idea's before I buy a new ignition control and crankshaft sensor? I replaced the crankshaft sensor and the truck runs great, they are around $50 and not too hard to replace. the sensor is on top of the bell housing on the passenger side of the truck.
16 people like thisFlag inappropiate
2002 Dodge Ram 1500130,000
my dodge 1500 will start run for 10 mins and wont crank back till it cools off. We have changed full pump and sensors but still wont run right
4 people like thisFlag inappropiate
2001 Dodge Ram 1500179,000
have same thing going on
1 person likes thisFlag inappropiate
2003 Dodge Ram 1500170,000
V6 3,7 my truck starts perfectly, but after 10 minutes of using it, it turns off suddenly. Then I start the truck again and it starts normal. So the problem is that my truck turns off itself after 10 minutes of using it.
1 person likes thisFlag inappropiate
2003 Dodge Ram 1500150,000
Same problem. Replaced camshaft sensor and spark plugs. Still doesn't work run after it warms up.
1 person likes thisFlag inappropiate
When starting truck cold, it runs perfect. After truck warms up starts to idle bad, and also starts making a loud suction noise like a vacuum leak. There's no vacuum leak ,the noise comes from the throttle body. If I turn off the truck and turn back on , it starts up fine till 5 min. later when it starts all over again.
My coil was cracked on back side where I could not see
Have not been able to fix
Related Items:
truck has a 5.2 engine truck started running really rough backfiring and sputtering like it was running out of gas until it stalled out on me i got it to start back up got about 6 blocks down the r...
i have replaced the aic,crank shaft sensor, tbc,map sensor,cam sensor,coil, cap and bug and my...
started easily/idled truck to warm up for 25 minutes; engine then just stopped running (still w...
4.7 L V8, recently had factory battery replaced, oil changed, and state inspection done. Only d...
It will only run for several miles before it over heats and dies

Related Content