Starting Noise on 2000 Chevrolet Impala

I start my Impala with no problem - there is something going on like the engine is shifting into place - then a loud squeal for no more than 15 seconds - then the car is fine - drives fine - no other issues. It is starting to do this everytime I start it. The dealer said it was the Air Pump. Spend $626 and the problem is still there. They changed some hoses but can't seem to diagnose the problem. No codes come up in message center.

by in Hugo, MN on October 29, 2009
1 answer
ANSWER by on October 30, 2009
Problems with the air pump on your 2000 Chevrolet Impala are not uncommon. In most cases the problems are caused buy water intrusion into the pump assembly. The hoses that were replaced along with the pump are designed to help eliminate the water intrusion issue. The air pump runs on initial start up for a short time - but apparently this was not the cause of your noise. Unfortunately your problem may need to be re-diagnosed (by the dealer or someone else). It should not be to difficult to properly diagnose a nose that occurs every time you start the engine.
1 person likes thisFlag inappropiateReply
Related Items:
When I shut the car off a loud clicking noise begins located up by the passengers dashboard area. The noise continues for about a minute then stops. So far it does'nt seem to be affecting the perfo...
i have a noise that sounds like it coming from tension pulley area. guy at advance said that my...
Ive had rotors shaved and turned. Also had brakes replaced
The steering may develop a clunk type noise from the upper intermediate steering shaft.  Our technicians tell us that you should check with your local GM dealer to find out what the latest rep...
One guy thought it was a piston going bad because of the noise and needed a engine. Another guy said the car isn't smoking, losing power,losing compression,losing oil pressure, or radiator fuild an...