starting issue on 2008 Mercury Milan

One day tried to start the car wouldn't start. Thought the battery was dead but lights and everything came on normal. Kept turning the ignition key on and of for awhile and car eventually started. Noticed that sometimes the key remote to set alarm doesn't work. Folks have suggested that the computer needs to be reset what do you folks think.

by in Philadelphia, PA on August 10, 2010
1 answer
ANSWER by on August 10, 2010
Your battery is weak. I'd be willing to bet that if you got it tested, it is not within spec, and that's why you're seeing this behavior. You car is so new, the battery really shouldn't be weak this soon, so there may be a draw on it. You may want to visit a shop for some help.
Related Items:
I have 74k miles and this just recently started happening. This jerking/hard shifting ALWAYS happens when I'm going up mountain hills and it seems like it happens when I'm in 4th gear and need to d...
Problem only once. Car would start ( engine ) but when you tried to go forward or reverse it would appear to put on the brakes and not move. The engine would only idle. With thmy foot off the accel...
The automatic transmission may develop shifting concerns. On lower mileage vehicles, upgrading the software in the powertrain control module (PCM) and the transmission control module (TCM) may corr...
RPM's Sputterd and engine felt jerky. when I parked the car and tried mash the pedal it would not even rev and a yellow wrench symbol appeared on dash. I turned the car off checked oil and transmis...
Started car and drove it,arrived at destination and put the car in park. Turned off engine and key will not come out of ignition. What can I do ?