starting on 2002 Buick Century

I drove the car 350 miles stop to eat and when I came out it would not start. I have changed the plugs and fuel filter. I have fire to the plugs and when I put a code tester on it I got P0341 which it a camshaft position sensor. Turns over but will not start do you any ideas?

by in Warrenton, MO on March 06, 2009
1 answer
ANSWER by on March 06, 2009
A Camshaft position sensor code can cause a no start. It will not allow the injectors to fire. The Camshaft Position Sensor is needed to start to the sequential injector firing process. I would recommend using a genuine GM part.
Related Items:
Car starts but then after turning off car will not start but will start later
ok this morning i went to go start my car and nothing, no clicking , no anything but the lights,radio, and evrything else came on i don't know how to check my starter or anything like that so i nee...
...tor cleaner and some heet in it started 2 more times with the same miss and sputter then tried starting it again and the battery was dead. boosted it off the next day and it started right up ran per...
it runs and idles great but stalls somtimes. it may start rigth back up or takes a couple mins. yesterday i drove it in the morning for about 30 to 40 mins stopping at a couple places came home for...
My grandparents have the 1994 Buick Century and recently after a day of sitting in the garage it will not start. It is not the battery I had it tested, when you turn the key you hear a few clicks ...