Chevrolet
Impala SS
13

Stalling or Low Engine Idle Speed Due to Dirty Throttle Body on Chevrolet Impala SS

Problem Description and Possible Solution

A dirty throttle body may cause a lower than normal idle and possible stalling condition. Performing a throttle body service will commonly correct this concern.

Problem Data
RepairPal Verified
Average mileage: 99,571 (72,000–120,000)
Engine affected: 5.3L V8
4 model years affected: 2006, 2007, 2008, 2009
13 people reported this problem
Comments
Viewing 1 - 4 of 4 comments
Low engine idle plus stalling
The normal RPM for my 2006 SS is 700-800 and closer to 1000 when the air is on.
As of right now- it's idling at 500-600 and stalling out after a 30sec to 2 min of idle time.

I hope it's only a dirty throttle body- I just replaced the plugs and wires as well as the Evap soilenoid canister.

My SS is quite the head turner with the Electric cutout and straight pipe.

I was able to remove the cat completely and trick the emissions system by welding a spark plug defouler into the pipe and using trhat to hold the second o2 sensor.

With the k&n cold air intake- this thing flat out gets it.

Sittin on 22" it looks and sounds mean. But people sleep on it.

I've run it with every new car-
Camaro-15'
Challenger 6.1 Hemi-15'
Mustang- coyote 5.0
300-srt8

And have yet to lose. This Impala is part of the family- it will stay as such forever. Blood sweat and tears plus a bit of $ have created a bond that is unexplainable to anyone who hasn't felt about their car that way.

I am happy to help anyone out who has a problem with their SS as I've gone through everything on it more than 1ce.

Thanks all -
My car first started with the abs and traction light on followed by a reduce power engine coming on causing my car to go no faster then 20mph, I would then have to pull over turn the car off wait a minute start it back up and it would turn back on normal. After getting a mechanic to check it he said a sensor was causing the problem, he reset the computer and all lights came off and no engine power reduce has came on since then. When buying the vechile I got it checked and was told it would have a throttle body issue in the future that day has come and now my traction light has come on and causes the car to shake and shift hard when the gears are switching I'm hoping and praying it doesn't cause an issue with my transmission but I was told I would have to switch out the throttle and pedals :/ I think after this investment I may start Saving for a new car and hand this one down to my father in law I love my SS but for the money I know I will spend fixing it I might as well get a new car and know if it has problems it's because of me
slow take off going into 1st and 2nd gear but drives normal in other gears