stalling issues on 2003 Nissan Altima

My altima has been working fine up until today ... I tried starting my car but its stalling. Put it in drive gave it gas but it didn't move .. so I put in park then back to drive. It pulled off but no matter far the peddle was down it wouldn't go pass 30mph . The battery/sevice engine light were both on. Then after about 5 miles it picked up speed and was back to normal. Could anyone please help me out with this problem? Thank You!

by in Baton Rouge, LA on February 07, 2011
1 answer 3 comments
ANSWER by on February 07, 2011
take it down and have the mass air flow sensor checked , i had sentra that was doing the same thing , and when i replaced it , it never stalled again .
COMMENT by on February 07, 2011
Thank u! And where is that located? I'm tryna rule out the fuel pump and cataylic converter. .
COMMENT by on February 07, 2011
the mass air flow sensor is mounted right on the air intake tube between the air filter box and the trottle body , well atleast on a sentra , its been along time since ive been under the hood of an altima
COMMENT by on February 07, 2011
K! Ty!!!!
Related Items:
96' Altima GXE failed smog because it stalled during the timing portion of my smog test. Per t...
I own a 1996 Nissan Altima. I just put spark plugs and wires and a fuel filter in and had the fuel pump checked. Every time I put the car in gear it stalls. What can be causing this?
I have a 2003 Nissan Altima 2.5 S model, and been the only owner of this car; and it has had minor and major issues, but overall it is a great car. My concerns/issues now are numbered below: 1)...
There is a new feul Filter, i have checked the feul pump and there is lots of feul flow at least to the feul rail. i thought it may be clogged injectors. When this started a few days ago, we were d...
Crankshaft and camshaft position sensors can leak oil into the connector causing Check Engine Light illumination. The engine may also stall as a result. Leaking sensors should be replaced. Certain ...

Related Content