stalling on 2000 Nissan Maxima

For some reason my car started stalling,has 120000 miles. Have replaced spark plugs wires @80,000miles this problem started about a month ago. The service engine illuminated today the code reads 0505 what i did before it illuminated i was adjusting the fuel screw to give it a little more acceleration so it would not stall on me but seem to made it worse.

by in Austin, TX on October 03, 2009
1 answer
ANSWER by on October 23, 2009
Hi, yeah, trying to make adjustments will only make it worse. The code is related to the idle valve circuit. I would try cleaning it and checking and fixing any vacuum leaks. You will need to reset any adjustments you tried making too.
Related Items:
I just changed the oil and plugs on my 98 maxima then I test drove it and it started to jerk and stalled then I seen some power steering fluid leaking from the hose near the crankshaft sensor would...
The Camshaft position sensor can leak oil into its electrical connector causing the Check Engine light to illuminate. The engine may also stall intermittently as a result.
I was told I needed a mass air flow sensor. The car stalls a lot at times, I've had many sensors replaced, as well as fuel injectors, etc. It always seems to stall after driving for awhile. I can s...
I have a 1999 Nissan Maxima,86,000 miles.For about a month on and off when I start it if I dont give it gas right away it would stall.Now,it wont start in park,only in neutral.
If I shift to neutral and rev it a little then it will go does anyone know what's going on with it?