Speedometer on 1995 Ford Explorer

I just recently had a rebuilt transmission put into my truck which is working fine. But now my speedometer doesnt work properly. Sometimes when I drive it the speed shows accurately on the speedometer but other times when I drive it the speedometer stays on zero. Is this something that was casued by the replacement of the transmission or is there something different wrong with it? My transmission is under a two year warranty, I just want to find out if this is a new problem that can be easily fixed or something I will ahve to go back to the shop to have fixed? Thanks

by in Houston, TX on June 19, 2011
1 answer
ANSWER by on June 19, 2011
Go back to where the transmission was installed - sounds like a vehicle speed sensor issue, but it could be a wiring issue as well. Have the wiring and sensors rechecked.
Related Items:
I don't know the code. All I know is that I let me friend borrow the truck and he told me that he had a mechanic friend disable the ABS. I did the inspection of the fuses and everything looks goo...
...would cause all of these things to go out at the same time. I tried replacing the fuse for the speedometer but as soon as I put it in it blew out and had a burning smell.
...d just lost the higher gears or perhaps it was 3rd gear. Now it does not engage power and the speedometer shows movement when the car is dead still.
The check engine light goes on and off the abs light is staying on and all the other gauges work
speedomitor doesnt work and I need to replace the censor I need the location to replace the part