» » »

Honda Q&A

Ask Your Question

2005 Honda Odyssey Question: Slipping/Juddering when ECO light comes on

 

Question

fergnes, 3.5L V6, Arlington, WA, November 24, 2009, 11:50
 Rookie

We have a 2005 Odyssey EX-L w/ 48k miles. When the van is traveling between 60-70mph there is a constant slipping/jerking sensation that seems to coincide w/ the ECO light coming on. The problem also exists at lower speeds but is not as consistent.

I have read many forums and it seems that it could either be the engine mounts or the torque converter. Honda Teachs can't diagnose the problem w/ their computers but do feel the slipping when driving. We've only had the car a week and it was not purchased at a Honda Dealer. I'm curious if anyone else is having this sort of problem and what they did to solve it. Thanks

1 Answer
Flag This
  • Answer #1

    rdude135 November 25, 2009, 05:14
     Journeyman

    Your vehicle has an ECO mode that will run the engine on three cylinders under specific circumstances. There are special liquid filled mounts to absorb the rough running engine when in this mode. The slipping/jerking you describe could be related to a bad mount or mount malfunctioning. I have seen these mounts go bad so it's not that uncommon. Other possibilities include a transmission problem but I would go in the direction of a malfunctioning/bad mount only because of the ECO light. If the technician can experience the problem they should be able to diagnose and repair the issue.

    Reply
    Flag This