Shifts hard in low gears? on 2000 Lexus RX300

We had the bank1 and bank2 oxygen sensors replaced once they are disconnected the shifting issue subsides, but reconnected the shifting hard happens in low gear 2000 and 3000 rpms?

by in South Bend, IN on July 11, 2013
1 answer 1 comment
ANSWER by on July 11, 2013
Sounds like going into a limp mode...are there any Check engine light or malfunction lights? Have you used OEM sensors?
COMMENT by on July 11, 2013
we replaced the air fuel sensor, air mass flow sensors and prior to all including the O2 sensors that were OEM specs made for the particular type of Lexus model Bosch brand we had service engine soon light come on and gave the code for the air fuel sensors and possible coolant issues so they also replaced the thermostat and seal, no codes have come on since and it is shifting hard when you approach 20 and then again when you approach 30, once you reach above that speed it drives fine! Ironically, when the O2 sensors were removed and test drove the shifting issues did not happen and the shifting issues were not present prior to replacing these sensors. We also removed the new sensors and replaced with new ones just incase they were faulty and still the shifting issue happened. HELP.....we were told by a Lexus dealer also that is the tranny and that the valve body could possibly be bad. Well we took it to a transmission tech and he stated there is nothing wrong with the tranny and that it is a misfire in the bank1 oem sensor. So this is why both oem sensors were replaced with new ones just to be sure...we have so far spent 1200.00 bucks and none of this was happening till the O2 sensors were replaced???