2002 Saturn Vue Q&A

2002 Saturn Vue Question: replaced plugs valve cover gaskets oil cooler put everything back together idle

checked codes had a bunch of them. was told to remove disconnect battery and would reset computer. did not work.????// -
Answer 1
you might have to drive it on highway for 20 min or so ,is the check engine light on? -
Comment 1
its missing and chugging what would going out on the highway do? -
Answer 2
What was it running like BEFORE the parts replacement?Knowing that (why was that stuff replaced?) , would help. -
Comment 1
valve cover gaskets were leaking, water pump was leaking, oil cooler was leaking into cooling system, plugs and timing belt due at 100,000 miles it has 95000 miles on it so I did everything it needed all at once. Engine ran like new very strong loads of quick torque never even a miss was perfect. I would not have put the time and money into it otherwise. When I put it back together the idle was low and it was missing all over not just one cylinder could not find any leaks. I took it all apart again and checked everything and put in the best plugs I could get. Still has very low idle and missing. -
Comment 2
Must be the V6, this is just a guesss, if you switched the coil modules would it cause this or can they even be swtiched? I do know there is a front bank and a rear bank that has to be in the right place. Everything back in time when belt replaced? Also for the heck of it what are/were the codes? -
Comment 3
i did the timing belt first it ran grate after that i made sure it was ok for about 3 weeks before doing the rest if the plug banks are switched it would not start. I guess I will just go and have it flashed -