» » »

Kia Q&A

Ask Your Question

2001 Kia Sportage Question: random misfire with access ram memory error

 

Question

sportsman270, 2.0L 4 Cylinder, Lawndale, NC, November 23, 2010, 13:37
 Rookie

My 2001 sportage developed a skip and the egnine codes are coming up random cyl. misfire with random access ram memory error. the car has 103,000 miles on it. It has had timing belt and tenisioner replaced, both coil packs and wires also sparkplugs.The misfire happened so fast and quick that #2 cyl. blew the sparkplug out. So we repaired it with helicoil and it holds good compression in th 130 psi range.All cyl check this good. My next step I sent the ecu off for repair. It came back with note stating the coil drivers had ben repaired and unit check good. Replaced the ecu in car run fine for about a week. Check engine light came back on so did random skip and same codes. where do i look now?

1 Answer
Flag This
  • Answer #1

    dandd November 23, 2010, 17:55
    Profile_thumbnail
     Master

    If you only have 130 pis, your engine is very weak. Many factories would condemn and engine with 127 psi or less.
    The misfire may be from a tired engine. What is the compression in the rest of the cylinders? Also, some thing was wrong with that spark plug hole , a misfire should NEVER blow out a plug, the only way that would happen is if the threads were already weak or the plug was loose.

    Flag This
  • Reply

    sportsman270, December 14, 2010, 08:35
     Rookie

    I shoud have said all cyl, check above 130 psi. When is running good you can step on gas and you have plenty of power. As far as the sparkplug they were all torqued down when changed.It pulled all of the threads out when the plug came out had to retap and install heli coil. I sent ecu off and they repaired the coil drivers and tested then returned. Ran good for about a week now problem is back. IT SHOWED SAME CODE AS BEFORE. CHECK ENGINE LIGHT WILL COME ON AND OFF. Now its on with no codes and shows it will pass inspection with light on. NOW WHAT?

    Flag This
  • Reply

    Visitor, March 30, 2011, 08:42

    HAVING SAME SKIPPING PROBLEM WITH MY 1997, CHANGED TIMING BELT, BOTH COILS, PLUGS AND THROTTLE POSITION INDICATOR, SOMEDAYS RUNS SMOOTH AS SILK OTHERS SKIPS RIGHT OFF, I HAVE FOUND THAT IF IT START DOING IT WHEN YOU FIRST ACCELERATE YOU CAN SLIP IT IN NUETRAL AND RESTART AND PROBLEM WILL GO AWAY FOR TIME BEING, SO SOMETHING IS BEING RESET, HELP PEOPLE!!!

    Reply
    Flag This