Toyota Tacoma Questions

Unanswered Toyota Tacoma Questions

Ask a Question
View:RecentAnsweredUnanswered
my tire on passenger side makes a grinding noise. I already changed wheel bearings on both side but noise continues. I was wondering if I can get any tips to help me find out where the noise is coming from. thanks a l...
3 mos. after buying it new, manifold cracked. Dealer replaced it. broke again before she got out of the lot. dealer fixed it again. less than 1/2 mile out of the lot, again it broke. and again...and again. this is not...
I was backing up and bumped the shifter with my knee knocking it out of 4wd and the light hasn't worked since and it won't engage. Sensor??? Vacumn??? Fuse??? Please help!!!! I took the front hubs off and cleaned and ...
start you crank it. And it gets to start but won't
Dash indicators also freeze on solid. have replaced all rear bulbs (both sides)
has fire fuel pump working, we are stuck, also chcked efi relay ok! stabs in dark ok.
Another shop put in new actuators and a used ECM before came to us. Can engage 4th with scanner. Reading data you can see all other gears working. Stuck on these speed signals. VSS never goes more than 22mph, Speedo i...
My Toyota dealer service said my 2010 Tacoma 4wd with only 54000 very gently used miles has a leak in the power steering gear that will cost approx. $1400 to replace. I have never seen any spot on my garage floor and...
A cruise control was installed recently. Not sure if it happened at the same time, I noticed it shortly after.
150k, what all maintenance/repairs neded? Timing belt, upper belts and hoses, etc.....
will shift into 2nd after 4000 rpm's but does not go into 3rd also idle will surge at a stop
I had the timming set wrong took it to mech he says it has no compression but he still has the timming chain cover and vale cover off is this true can you tell about compression with all that open ?
Check engine light came on the same time this started hard to get in gear.
Failed for overall computer readiness... ????
I failed an emission test for an overall readiness result... ODB... it it because i disconnected the battery?
I have removed the trim and taken the heater control loose from the dash, but I can't figure out how to get it free of the cables.