Close

Toyota Sequoia Questions

Get answers to questions about your Toyota Sequoia at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
343
questions

to, fixed then cleared.

When I got the car it was ticking, pretty loudly and pored white smoke out the exaust. I was told it was the rod barrings, the top barrings showed signs of wear so I replaced them. Finally got it back together and started it up and it hammered louder than before. I did notice it was not poring white smoke anymore. The check engine light is on and has been on from what I understand. I haven't been able to run it for codes yet, I'm afraid to leave it running for long,(I don't have a scanner) and don't want to cause anymore damage.

This problem persist when the car is switched off and later switched on.

front wheels vibrating when applying brakes

Sequoia 4 wheel drive limited v8 w/159000 miles feels like the rear tires are flat when I back out of the garage/drive and sometimes when I first start to drive forward. Happens frequently, every couple to every day. Once I have been driving for a minute or two, it drives fine (no more bucking or flat tire feeling). What could cause this to occur?

I just observed that the coolant level in my 2002 Toyota Sequoia keeps slowly going down to halfway between Full and Low, in about 12 to 24 hours, whether driving or parked. I removed the skidplate and noticed coolant dripping slowly along the lower edges of the radiator. The hose there seems ok. Would it be wise load up on a few gallons of coolant, take my time home, stopping every hour or so to check the level? Travelling will be about 12 hours. Thanks for helpful answers.

This problem happens all the time. I also smell something burning when I'm driving.

right above were the side air bags are located any ideas why

I want to believe that it has occurred due to me kinda pumping (tapping) on the brakes to come to a complete stop. If I turn off my vehicle and turn it back on, the lights will not turn back on. Should my brake system be service, and if yes, than what in particular should I have done?

The light continued to blink and I did feel the cruise control moving my vehicle. Tried turn it off but it stayed blinking. About 10 minutes later it turned off on its own. Should I be concerned?

KEEPS BLOWING THE ETCS FUSE

2 months ago I had an autostart put in it. since then I have had to jump it twice. went back to the shop and was told that the lights had to be in the off position not auto. changed that. yesterday it just wouldn't start. put in a new battery. dash lights are on. doesn't even try to start. auto start does not start it either. some say I am locked out, could be alternator...ideas??

won't open

my daughter (2) years old. pushed the 4wd button while vehicle was off, turned vehicle on and the 4 green tire came on. and a orange circle light started blinking. got the fluids changed since i had just bought it from someone who didn't use the 4wd often. so i read up n thought that might b it. i try to reset it by disconnecting the battery, taking out fuse, and replacing fluids n nothing. still blinking. car drives fine. no noise no weird transmission jerks or noises. i already spend 230 changing fluids, in differentials and transfer case. and light still on.
flashing.could it maybe b we dont really know how to engage disengage 4wd?? how to lock transfer case? please help. i am in mist of starting my own Business i have no room for major work on this truck. i would appreciate any related info.

diagnostics says port 1 and port 4 is running lean

I am finding some are 2 wire and some are 4 wire for the same location sensor. how do I know which I need?

Do not hear when driving on highway or street. Occurs when turning and parking. Sounds like a squeaky spring. Have replaced lower ball joints 30,000 miles ago.
Have 334,000 on vehicle but keep it maintained. Travel 40,000 per year highway miles. This sound is embarrassing when I pull in a parking lot. Just started two days ago and I am 1000 miles from home.

My husband drove my Sequoia 2 days ago on the ice/snowy road w/no problems. Today I attempted to drive it myself but the VSC light shows off & every time I attempt to change it over to 4HI or back to even 2wd my 4Lo button flashes & beeps continuously until I change it back to 4Lo. My vehicle acts like it doesnt want to go & has a winding sound if my speed gets 30 or over. I have owned this veh for 3 Winters & never had an issue. HELP!

Yesterday, when I turned on my turn signal, the radio shut off but then went right back on. This happened a total of 3 times yesterday. It probably did it 3 out of 7 times. Then when I got in my car today, the clock was the wrong time. I reset it, but then when I got out of work it was the wrong time again. I reset again, went to the store and again it was the wrong time. Any ideas? Thankyou:)

How do I ohm out my Throttle Position Sensor? At an idle it drops to under 500 RPMS at Highway Speeds the Check Engine light goes off.

My engine light is on and the vsc tracking light says vsc track off, how do i turn it off or is there something wrong with engine?

The fuse that controls my rear lights keep blowing it stormed here and that's when this started.So far I've only replaced the fuse and after driving a shirt distance it blew also please help???

Last time I did it was about 7 monthes ago but my question is do I need to change the oil filter and spark plugs too? On the last tuneup I did change them

Door locks cycle on and off. Happens during wet weather and usually takes 2-3 hours of driving. Sounds like there is a relay shorting out so that even though the doors are already locked, it attempts to relock them. If I unlock doors using the rocker switch, immediately locks them. Then the lock mechanism tries to lock them again, and cycles through this every 10 seconds to 3-4 minutes randomly. Is there a relay under the hood which might do this when moisture enters the engine compartment? If so, where is it located and what is the part number. Help! This is driving me crazy!

Hi, test drove a 2007 sequoia 4wd with 54,000 miles. Loved the truck and really wanted to buy it, but while on the highway at 60mph and above, I noticed a low constant rumble sound with a very mild vibration in the chassis. Also, noticed a transmission or driveshaft clunk a few times while coming to a stop. Any ideas? Thanks so much!

Its having a hard time shifting, like its staying in the same gear then jerks when it shifts into a higher gear. And that's barely taking off from a stop (not taking off fast). I checked the Tranny fluid's its normal, but I'm so lost. Can it be a DIY or would I have to take it to the shop?!?

It seemed to be dragging when I accelerated above 35 miles per hour. The check engine light came on and now I am told to replace the transmission assembly.