466
questions

The problem seems to occur after the car has been driven for a while ( heat related problem? ). The car will start in the morning, I go shopping. Park. Go shopping come out 30 mins later and the car won't start. But if I jump the car it will start. I have changed the Starter, Battery, cables going to the Battery ( Positive and Negative ). Don't know what else to do.

I have changed the distributor an re checked the new timing belt. "HELP"

so the heating system in my car works very well, but the only problem is, is that the cold one doesn't i was wondering what could it be that doesnt work? and how much is it going to cost to fix it?

I had to replace the fuel filter and main fuel line, after that I noticed car started running worse when I stopped for fuel and removed the gas cap, there was no hissing sound as if there was no pressure in the line.

I was forced to cut the main fuel line to remove the fuel filter and now need to replace it.

any suggestions of simple items to check?

I already removed both CV axle not realizing that the pinion with slide downnow I have a piece of broken aw axel in my transmission how do I remove 2000 Celica GTS

didn't realize that I couldn't pull both cv axles at the same time and pinion slid down and now I can't bang out the broken stub from the axle what do I do

I can see the rubber is torn, deteriorated. Do you have to replace the whole strut? Would it be worth it to find good struts at the wrecking yard? Or are new ones the only way to go?

I have a 95 Celica GT 2.2 with 335,000 miles...I have never changed the fuel filter and am experiencing sluggish take off and not so great mpg.

I've checked the bulbs, they are both good but when i put my car in the reverse gear, the lights wont come on?

Is the rattle I hear in the rear a result of bad shocks?

Just bought the car a couple of months ago. Was sitting for a full year and It seems like a good idea.

Just replaced the old battery. It kept dying. New battery. Car starts and runs fine but the running lights stay on when I shut off the car.

I need to replace my rack and am wondering if the transaxles need to be removed and if so I suppose I should change the transaxle seals also?

intermittent problem motor bogs down or shuts off when driving check engine comes on then goes off and motor runs normal.this happens 2 or 3 times on a 20 mile trip one day and then not again for 3 or 5 days. Does it at different speeds

Tac is not working how do you trouble shoot to fix?

I am having trouble finding out how to do this. Also where it is located to please. I am almost positive I found it but I want to be sure.

Had a hard time starting finally did ran about ten miles then died in tbe process i broke a sensor that went to a line where water ran through

Acts if it wants to start almost feels like its not getting enough gas and it will not start. And the engine got really hot

even after new tires,cv axles,wheel bearings,new hubs,3 alignments,4 new rims,new front and rear motor mounts,new rear struts and 7 tires in all I still can not figure out where or what is causing this vibration that really gets bad at 50 to 80 MPH please help me I just can not understand what it could be

motor/replaced then remove dnw.tune uo im lost.???

My cruise was working minutes b4 I had replaced my alarm system I noticed the cruise control was not working afterward... I checked and the piece of rubber that extends from the clutch pedal to the cruise control is not there... This is what engages the cruise

The engine revs between shifting from 1st to 2nd gear and then it slam's in to second gear.

Got a 1989 Mr2 non turbo..gasoline smell in side of car..don't see any leaks..help

It goes into second gear but won't engage, if you play around with it sitting there you can put it into all 5 gears without the clutch in.... When you put clutch in and try for reverse, it's hard to do but goes eventually. Now it will go back into first and move as long as you don't take it out of first or you start back at square one. Anyone got any suggestions?

No diagnostic codes displayed.
Timing belt was changed approx. 10000 miles ago.
replaced distributor cap, rotor, plugs and wires.