311
questions

code reader said caticlac so I changed catlic converter but it still acts like someone shut off the gas while your driving and then after a minute turn it back on

We're looking for a nice used car for our daughter. She fell in love with a 2002 Suzuki Grand Vitara with only 61,000 miles on it. It's in GREAT condition on the exterior and interior. My husband doesn't want to get it because he thinks it will be too expensive to maintain. Opinions???

just replaced the engine ....
it is going above 1 km when idle ...
i am using a 11 plate battery ...

I have always had trouble with my low beams. If one burns out the other goes too. Recently I was told it was the switch but I could still turn on the high beams and my blinkers worked and I always use auto. so even if the switch went out they should still come one automatically I would think and if the switch broke wouldn't that also mean I wouldn't be able to switch to the highbeams.

2 1/2 qt low. Tried to turn over n heard loud clunk. Pulled home. fan motor moved barely on turning key. Now fan don't move. Checked starter. It good.. Does a click then light sound of tick tick tick then nothing. Any idea what could be? Please help me.

In winter the heater only gives off heat if the car is driven. If I stop at a stop sign, it immediately goes cold and then goes back to heat once I start driving again. Had the rad flushed but did not help at all. Yes, liquid levels are good and the thermostat was replaced.
Help please as winter is coming soon......à

Pierre

I have a XL-7 4X4 with automatic transmission 230000 miles on it, in the mournings I have trouble with the rear gear it din't engage until I accelerate several times strongly, after it engaged and the car moves rear, then I use the car normally and the rear possition engage just fine for the rest of the day unless it is park for more tan three or four hours in the same place then it do the same again.

Can smell gas also

The driver's side door is stuck locked. It can't be unlocked with the key or by pulling on it manually.

Have a 2000 Suzuki grand vitara that had code for p0300. Changed out 3 bad coils and 4 bad injectors. Now vehicle starts ok but won't stay running at an idle. No more check engine lights. My scanner quit working so can't give any more sensor specific info.

Shops cannot find problem. Differential fluid was one guess but it's fine. weather is hot

It was working fine this morning on my way into work then at lunch when I got in it would not blow anything. I cant hear anything either

Working on said truck which has a small 1/4inch ID hose which goes under intake manifold on left side. It is leaking coolant on top of engine block

I have no rear lights when I have my lights set so that I can see the dashboard. If I switch to a different setting where I can use the bright lights I have rear lights but can't see the dashboard lights I always have brake lights.

Sometimes the car will start and run then other times it will just continue to turn over and not start it stopped in the middle of driving then wouldn't start for 2 days then when I went back it started right up the starter turns over just fine

At first it started with having to give the car some gas while in park after starting it to keep it running as well as immediately shutting off when going from drive to park. Then it went from that to starting fine in park, and dying(rpms drop to zero and car shuts off) when putting it into drive. Currently, it starts fine and runs fine in park, but when I shift into any other gear it dies, forcing me to give it some gas then put it into gear which I know isn't good for an automatic, but when I if I let off the gas like coming to a stop or turning rpms drop to 400 and then dies. A computer diagnostic was ran at a local repair shop and the guy told me nothing was coming up. He tried to, what he explained to me as, a system reset and the problem was still not resolved.