Close

Subaru Legacy Questions

Get answers to questions about your Subaru Legacy at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
360
questions

Car is Stalling around 1500 to 2000rpm had the spark plugs and wires changed. i also had the mass airflow sensor replaced all this cost about $1,000 in parts and labor and it didnt fix anything! any advice would be greatly appreciated.

lic plate light and dash lights all come on have to give it gas to start

This morning I drove roughly 10 miles round trip and used an eighth tank of gas. Any idea what could cause this.

Gauge moved back down when I shut the heat off. What is wrong? Note: problem occurred after three to four days of running heat w defrost. It didn't happen right away.


Thank you for your help,
Cydney

check engine light comes and goes. code said too much oxygen . car will shut down, even when driving . anyone had this problem and knows how to fix it?

A 1998 Subaru Legacy l wagon could have either a 2.5 L engine, or a 2.2 liter engine, isn't that so?

Does gas tank have to come out to pinpoint a leak in a brake line on 1998 subaru wagon?

Or a sensor.

Im trying to order some front axles for my legacy wagon AWD. Everything I find keeps saying "non abs" in the description. My abs is disabled anyway because it would continue running after I shut the car off so I don't really care about abs. Can I put "non abs" axles on my car and call it good?
Thanks for any help and sorry if this question has already been answered.
Cheers

while repairing heads the lifters were knocked off and mixed up
working on 1999 leg. outback dohc , with motor in car

while repairing heads the lifters were knocked off and mixed up
working on 1999 leg. outback dohc

at oil temp light flashes

I had my battery tested and they told me it was in good condition. I have just recently replaced the alternator so I know it is good. Jet if I let my car sit overnight the battery is dead in the morning. If I disconnect the battery it holds a charge just fine.

I purchased a 2004 subaru legacy anniversary model used. It now has 130,000 miles. Since I have had it I have had to change the rear rotors and brake pads 3 times!!! Anyone have any ideas why?

I pulled the starter and had it checked it is in great working order, for the last year sometimes i turn the key and just get a click and sometimes it started, the last week i cant get it to crank over even with jumper cables.. all the lights work inside and out.. I noticed when it got hot outside the problem got worse, so where ever i went i had to keep the car running encase it wouldn't stat again .. so now it is parked in driveway. will not crank over, when it did crank over it started up right away .. i REPLACED the alternator, battery, and starter 3 years ago.. any help on what to check now would be greatly appreciated .. thank you

If i continue to buy spark plugs, replacing the damp oil ones the car will start. If i need a head gasket, will the cost of repairs, be expensive? and how much if you know? Every time new plugs is replaced they r getting wet or damp from oil getting in plugs. The only way i can get the car to start and run for a short while at least for two weeks is to keep replacing spark plugs.

So using an obd tool i got the code p0051 for my 2004 Legacy (35th Anniversary Edition) and subsequently changed the bank 2 O2 sensor 1. I am now getting a p0151 code which is low voltage for that brand new sensor. Strangely enough, in trying numerous possible solutions (cleaning the mass air filter sensor, checking for leaks, ect) and turning the code off hoping it will stay that way, i sometimes get a p0152 code, which means high voltage for that same sensor. how can i be getting both? and how do i get rid of them? any help would greatly be appreciated. Also since im new here if theres a better place to post this question let me know, thanks folks!

my subaru stalls when i start it ,then put it into gear, unless i keep my foot on the gas pedal, my question is how hard is it to fix this problem and is it a sylinoid in the pan of the tranny?

It's in the compartment between the seats.