Close

Subaru Impreza Questions

Get answers to questions about your Subaru Impreza at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
192
questions

It has also started dropping down to 1k rpm and occassionally dies when pressure is taken of engine (such as pushing in the clutch) which is making it a pain to drive. I just purchased the car a month ago, it started with the rough idle 2 weeks ago and stalling 3 days ago. It has no cel and dealership originally said they seen nothing wrong, other than a emissions recall (which they did). I am lost. I have changed the plugs, wires, looked to a vacuum leak, even had a friend put a scan tool on it and found nothing.

I pulled the door panel and went to remove the switch and pulled it apart in the wrong spot . It looks like spagetti lol

It usually occurs after driving for a few minutes, speeds range from 25-50, also can occur when going over speed bumps, hasn't occurred yet at higher speeds. It stops when the brake is tapped or hit. The brakes were recently replaced and I've returned to the shop, they said they couldn't see anything wrong, Also clicking noise accelerating from stop or low speed.




Speedmetror not working. Chech engine light on.

the hydro carbon level was 161 out of 130

I just bought the car today and on the way home and when stopped at home with the engine still running the reverse lights are staying on

I have 2008 Subaru Impreza and my intermittent wipers are not working. The wipers also do not return all the way down when turned off but stay in the middle of the windshield. The Hi and Lo speeds are working fine.
I had a problem with the nut for the driver side wiper arm being loose.
I tightened the nut and the wiper works. After I fixed the loose nut problem I started having problems with intermittent mode. Since we are having lots of snow having wipers work would be very nice. Your advice greatly appreciated

My Subaru is 3 years old with 38,000 miles on it; I do mostly hwy driving to work. When taking it in for inspection, I passed but was told my front brakes are low, and they are bearing the braking load. Mechanic told me that rears "look almost brand new" because fronts are stopping the car. Is this normal or a defect?

THE LEFT SIDE OF MY HATCH BACK DOOR LEAKS WATER IN WHEN IT RAINS. i'VE HEARD THERE IS A PROBLEM WITH THE RUBBER SEAL. iS THERE A REPLACEMENT PRODUCT AVAILABLE

what is the best way to check my oil level,with engine warm or cold?when I check it cold the oil goes a third of the way up the curved stick and at times I have a difficult time to read level...

I thought it was the clutch safety start switch, but I replaced that and the car still won't start. When it was running fine, the starter never sounded like it was worn out or gave any signs of failure.
What could possibly be the problem?

Where would the engine fuse be located on my '93 Subaru Impreza L?

there is a similar question already on here with no answer..can someone give me all possible answers?

an idiot unamed here , putting in gas , swiveled around and tore off my fuel /gas cover to the outside on the rear fender..how do I fix it? the cover is fine but missing whatever springs or bolts or what holds it on to the inside release ..Help barbieiamiam

First off forgive my ignorance on engines. My father in law has installed a new engine in my son's 2005 Subaru impreza. It fires up just fine, but it leaks massive amounts of oil from the oil filter. He put a different filter on it and it did the same thing. My father in law thinks it may be too much oil pressure that is blowing the gasket off the filter. Any help or suggestions would be much appreciated. The good thing we a 3 year/50K warranty on it.

so when driving and i accelate it seems like the front like sort of in a way locks up. if you get what im saying. any answers would be great.

while driving with the heater on, strong fumes in car- had to turn off heater and drive with windows open in freezing temps! think i saw a greenish liquid under car on road after I parked.

Feels like I am riding in a truck. Has the rim replaced, new tires. still feels bounce like riding a horse lots of vibaration in the rear of car

2.5 automatic what is the normal gas milage?

I have 2008 Subaru Impreza and my intermittent wipers are not working. The wipers also do not return all the way down when turned off but stay in the middle of the windshield. The Hi and Lo speeds are working fine.
I had a problem with the nut for the driver side wiper arm being loose.
I tightened the nut and the wiper works. After I fixed the loose nut problem I started having problems with intermittent mode. Since we are having lots of snow having wipers work would be very nice. Your advice greatly appreciated.

the check engine light has been flashing for a year can't use the code reader because my car is a 93 the code reader is for 96 and up what do I do

Car makes a clicking noise in front end when making slow turns. I was told it might be the axle boot but not sure why a torn boot would cause a clicking noise. Car has 150000 miles on it

Even when I turned off the engine and remove the key from the ignition

I replace the crank shaft pulley and keyway about a month later
the pulley be came lose the key way broke in half . Just bought
a used pulley and a new keyway

Hi-
My Subaru Imprezza has 122K miles. I am taking it to my mechanic to have it looked over before I go on a road trip. Besides my timing belt what other maintenance issues should I have my mechanic check at this mileage level?

When driving car will get shakey and loose power the check engine light will flash. pull over turn off restart and will be fine. take and have a diagnostic done and it will read 3 and 4 missfire. Recently had a tune up and new coil put in. this happens about every two weeks or so with no warning. otherwise car runs fine.

I have been since January trying to get the stupid engine light to go off! I have had an emissions canister replaced and the oxygen sensor replaced...they tell me that the catalytic converter does not need replacing. My inspection is due in October... I have spent over a thousand dollars trying to solve this problem. I can't use the cruise control as it flashes continually...I am so frustrated. Anyone out there have any ideas? Thank you for any light you can shed on this!!!

I have a 2010 Subaru Impreza 2.5i premium 5 door, 5 speed with 8k mls on it. The car runs well and does not have any check engine lights on but there is a slight intermittent knock when switching gears and staring off in first. I was told by my Subaru service manager that the car only needs 87 octane and that I can experience occasional knock and that it is normal. I have been driving manuals for 25 years (both foreign and domestic) and never had this happen. Is this an issue I should push with the dealer and will it eventually destroy my engine? I was hoping to get at least 200k mls out of this car.

I just had an alternator put in. now I have a high pitched noise that cycles on and off after it warms up. I took it back to the mechanic who checked the alternator belt. he did not know what the sound was that he heard. it is in the center of the engine. thank you for any help you can offer

I'll try to explain this as best as I can. So I have a 1993 Subaru Impreza. When I'm driving the RPM's will jump up and down. I'll have it in drive going like 45 and the RPM's will be at around 2,000. Then they'll just jump up to around 4,000 or so. Sometimes it corrects itself and drops back down or I have to let off the gas a little. And it jumps practically no matter what speed I'm at. I don't know if this matters but it has sportshift so i can shift from 1st to 2nd to 3rd and then to drive. But when I'm in 1st, 2nd, or 3rd the RPM's dont jump at all. I've been told everything from it could be a transmission problem to it could be a throttle sensor. Any help would be greatly appreciated.

Thanks-
Matthew