409
questions

I have to add power steering fluid about every 3-4 days to keep it from making the wining noise when turning the steering wheel...

It had stoped on me while driving and shut off

2009 g6 2.4 showing p0411 and p0420, gm replaced the converter. p0420 cleared, still have p0411. Have replaced the air pump, check valve and intake hose, still showing code. gm payed for 1 hr. diagnostic at local dealer, said the light went out on its own when they tightened clamp on lower hose. drove it home next morning light on again, still showing po411, what next?

TOOK IT TO SHOP AND GOT OIL CHANGE HE SAID I SEE LITTLE UNDER CAR CANT TELL WHERE TIS COMING FROM.

The one that on the manafold in the back why is it so much money and everyone says you have to buy the dealer one.. You can't do it yourself because of the bolts will break

The last few weeks our 2009 G6 40000 miles 3.5 V6 has been missing out every little bit no codes in the computer new air filter and complete cleaning of fuel system, does any one have a answer short of trading it in?

the convertible top on my g6 yrys to go up but it kicks out and wont continue i have switched relays,hyd fluid is ok i wont go up with help from me manualy ,also i can manualy raise the trunk , help

I have a 2009 pontiac G6 and the engine light came on and the code read camshaft sensor. So I replaced the sensor and deleted the codes. Light is back on. I also noticed on the old sensor there was what looked like black burnt oil paste on old sensor. Not sure if that's command. Wondering what I should do nexted. Car runs fine but electric start won't work with engine light on.

My car is a 2008 ive only had this car for 3years....back in 2013 there was a recall on my shift cable i took it to the dealership where they said they fixed it (remind you its been the same shift cable in the car since 2008 when the car was made) Last week my shift cable went out....what i dont understand is if they fixed it the 1st time quote on quote then why 2years later the "NEW SHIFT CABLE" goes out in that case i should have kept the same one that was in the car to start from 2008-2013....i paid $216.00 to get my car fixed and they are telling me that i cant get my money back because they quote on quote fixed the problem in 2013 when i took it in for a recall....So my question is: Did anybody take there car in for a recall for the Shift cable and it still wasnt working or went out?

The sound changes in pitch dependent on the speed. It makes the sound regardless of engine speed as the sound doesn't change when I place the car in Neutral. It started about 2 weeks ago and it seems to be getting louder. At first it was intermittent but now it's constant. I replaced the front brakes but that didn't affect the noise. It seems to be coming from the front axle area.

Got transmission cable fixed on the recall then next day car won't start took it back now they saying it's the starter.the car act like it wants to start but wont.no codes came up

we tried to jump start the car and that didn't work, we checked all the fuses that we could,we even tried to disconnect the battery then hook it back up, nothing.. there is absolutely no power to the car what so ever

i have replaced and done the repair with or without shellac , done it with OEM and aftermarket seal just cant figure out why after replacing it will go a month or so then start to leak again

have replaced the seal numerous times continues to leak after a month or so would really like some advice on this matter. used OEM seals as well also used a shellac and have installed without shellac. any help is appreciated.i have done it so many times it takes 20 minutes to do the job from start to finish. does this vehicle come with a pcv valve if so where is it located

THIS IS THE FIRST TIME THIS HAS HAPPEN BUTI CANT ROLL UP MY MY WINDOW NEITHER DOWN FROMM EITHER DIVERS SIDE OR PASSANGERS SIDE .U CAN HERE THE MOTOR RUNNING WHEN U TRY TO PUT IT BACK UP

While the car is running and or off i can smell gasoline really strong. But yet dont see any leakage. What's the best explanation for this?

It open good but it will not complete top up

What is the problem here & what do I need to fix?

It occurs alot

The car has 55,000 and some change on it, i have already changed the brakes twice, the whole front end feels and sounds like its hanging on by a thread and now this. Anyone have an idea what it might be?

Having no performance problems. Should I start with the o 2 sensor?

And my anti theft light also comes on sometimes. The fuel gauge goes down to the empty and says low fuel when the gas tank is full. When I shut the car off and try and start it again it wont start. I leave it set for five minutes or so and try and start it and it starts again with no lights on. As Im driving the abs, tc and engine light comes on again and it also backfires
codes are: U2105, U2107, U2106, U0073, P0700

Low idol started and half the power on takeoff. Cooling fans not engaging. It hasn't overheated. Can I fix this myself? Where is the fuse that I need to change and the wire for the upgrade. Please tell me I don't have to spend $50+ to have some grease monkey change a fuse.
Thankyou

How do I know my mechanic put new rotors in front, rather than resurfacing my existing rotors?