396
questions

installing a new mode actuator and wondering if the settings need to be set to the same settings as the old actuator?

I replaced the coil pack and wires and plugs. It runs worse than B4. I checked the wires and they're connected good; checked the gap on plugs which is between 50 n 60. the codes I get are PO300...random misfire. starts good but it soon slows down an runs rough.

Where us the fuse located for the lighter in the fuse box?

Both visors have come loose and one finally fell off. The hardware is falling out of the ceiling. How can I fix this?

That's all I have.

i was sitting in a parking lot and my car stalled and would not restart. I have been told i need an engine because when the timing chain broke it caused engine damage

Already replace the relays and fuses and switch

A recall for the brake cable had been completed well, about a year ago, since then I have noticed a front end rattle..kind of sounds as if you had a screw with a washer ....but the connection is loose so it rattles....something like that..i cannot figure out where the hell it's coming from...I just a few days ago had a complete full service brake job.....so it isn't in the brakes.......i'm so annoyed with the consistent sound...

Mainly just occurs when I am shifting

Just after a long drive

Just when idling

My dash makes it seem like it's okay for 10,000 miles, but I've always been taught to change it every 3,000.

It only happens after I let off the brakes. It sounds like it's on my rear driver's side and it's a thump that goes at a pace similar to my tires rotating.

It burns out every 6 months. Only my passenger side.

Replaced pedal position sensor - nothing
Replaced throttle body - worked for 2 months
Checked body to ECM connectors/harness - looked good
Checked ECM to throttle position sensor - looked good and replaced - nothing

my car stalls as soon as it starts then refuses to start back. Check engine light comes on and service tractsion

There was no lights prior to the brake repair and I saw no sensors. Does anyone know how to reset the ABS and service the TC light.

My husband has has to replace the wiring harness once on the driver side and twice on the passenger side because it keeps getting so hot that it burn and melts the wiring harness. Has anybody else has this problem, or know of a recall for the problem?

Recently had oil change. He k engine light also coming on intermittently.

It would not accept the freon.
What do I check.

Last replacement was barely a week and a half ago. Shorted out again last night

air con and temp gauge both quit on me at the same time

Every time I take my floorats up the floors wet as can be. Under my back seats it looks as if I have a river lol any ideas what could be the problem with my Pontiac 2006 G6 any recalls I missed?

It just started to continue to run the engine fan after it is turned off

my g6 loses power when going up a hill. It does not die or spit and sputter. we have changed both cam sensor and put in new sparkplugs. What coulf be wrong with this car?

Is my engine locked

Every time I buy a new fuse for my car lighter to work it immediately blows out. I've tried 4 back to back, same results. Do I need to buy a new fuse box or if anything how much will it cost to repair to fix this issue?

I am hoping someone can help me? I got back from the Dentist almost 2 weeks ago and parked my car for the day. The next morning my anti-theft caution light only come on when tried to crank car and did nothing but click and there was a ticking sound like a bomb ticking coming from behind the cigarette lighter and A/C controls. Have tried new battery 2 times and car will crank fine, but after sits overnight battery dies for some reason nothing is on at all at night to drain it I have checked it. It cannot be alternator as it runs perfectly fine when it is running it only happens after you turn car off and sits awhile. This happened overnight. The car was running fine, except for valve that I got replaced until this.