611
questions

Hard shifting

I have a Pontiac Bonneville 2000 supercharged water pump went out so I have to replace it do I have to remote the motor to replace it

no radio,speedometer,heat,a/c,gauges work at all and were all working prior to mechanic putting in new fuel pump. the heads up speed works though

My bonneville starts to get a little too hot when it's idling (like sitting at a light or something) but once I start driving the temperature goes back down. what gives??? can anybody help me on this? drive perfectly fine besides that. just want to get it fixed.

Went out from work yesterday and car won't start! Everything else worked. Jumped it and started. Got home it starts , this morning it starts, get to work shut it off and it won't start, go out at lunch and it started right up. What is going on I've checked all the thing I could think of!

JUST replace a fuel pump.so #1,battery is dead.an have been for 2weeks. Got a charge,
Turn the key engine turn no gas is pumping,did it a couple of times.wen I turn the key I don't hear the fuel pump turning on.
#1,battery don't stay charged.#2,might have an electric problem? I need help.

I've had three cans of freon however you spell it put in and nothing checked fuses they are good went to woods battery they unplugged my negative on battery said it should reset I do not know what's wrong please help with answers thank you

A/C is charged but won't blow out cold air feels like the heater is stuck on an won't blow out the front only the floor an defrost

po440-po442

It was fine then outta nowhere it just wouldn't turn when i went to start.

Cold Engine surges at 1000- 2000 rpm and has rough idle till about 20 min., then it idles and runs normal. I unplugged the MAF sensor and the engine smoothed out and ran normal. Replaced MAF sensor with remanufactured MAF sensor ( not A/C Delco ) and the engine runs perfect. However, if I stop the car a few minutes and restart the warm engine, it surges badly, then stalls.Pretty much undriveable.

My heat and air barely work. The only time they do work is when I'm going more then 40 mph, and then they still don't blow enough to heat the whole car.

I passed everything on my emissions but my NOx was real high

Problem now for along period. Note battery will drain
if I leave it connected. don't know where to look for a short, or open. No codes read.

I have replaced the fuel filter,crank shaft sensor,coil pk, the cycl and/key. And the car will not start. it cranks but that's it. And the security light is on!!!! Please help this Greek Lady out!!!!

I have replaced the fuel filter,crank shaft sensor,coil pk, the cycl and/key. And the car will not start. it cranks but that's it. And the security light is on!!!! Please help this Greek Lady out!!!!

transmission making a whinning sound

Rear end rides low and scrapes over bumps and driveways. New shocks but airbags not filling up. The compressor works. Tried with 300 lbs in trunk still nothing adjusted level control sensor and still low. Now what? How do I test the sensor to see if it is good?